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1 General information 

Press-Right is a monitor and measuring device that is connected to a press and monitors 

the quality of productive processes. 

Being interfaced with a displacement transducer and a load cell, it continuously monitors 

its positions and instantaneous force.  

1.1 Notes on control theory 

During sample production, the data regarding cylinder position and the force exerted by it 

are entered; the following graph may be created: position-force representing production. 

If several runs are performed on similar pieces, their position-force curves will also be 

similar. On the other hand, if one of the manufactured pieces is different from the sample, 

its curve will be different from the sample. It is clear that monitoring the curve may affect 

the quality of manufacturing. 

1.2 Pressing cycle 

Each pressing cycle can be divided into different moments: 

1. Approach 

2. Contact 

3. Work 

4. Pre-arrest 

5. Wait 

6. Return 

During the approach, the cylinder advances to the End approach position.  

Once the approach is finished, the cylinder advances at the Contact speed until it 

comes into contact with the piece. 

During the work the cylinder advances at the Working speed until the stop value is 

reached. When the stop value is reached, the cylinder is stopped and a timer is started for 

the set time with Waiting before return. After the time has elapsed, the return of the 

cylinder is commanded with the Return speed. 

1.2.1 Approach 

During the approach, the cylinder advances to the End approach position. The 

approach takes place with the Approach speed. During the approach, the measured 

force must be less than the Collision force alarm configuration value. 

If you do not want to carry out the approach, you must set the end of approach position to 

zero. 

1.2.2 Contact 

Once the approach is finished, the cylinder advances at the Contact speed until it 

comes into contact with the piece. Contact with the workpiece is detected when the 

measured force exceeds the Force for contact detection control limit. If you do 

not want to perform the controlled support on the piece, you must set the Contact 

speed to zero. 



1.2.3 Work 

The work can be performed in two ways depending on whether the pre-stop is used or not. 

The work without pre-stop is performed when the Pre-stop position is equal to zero. 

Work without pre-stop 

During work without pre-stop the cylinder advances at the Working speed until the stop 

value is reached. Once the stop value has been reached, the cylinder is stopped. 

Work with pre-stop 

During work with pre-stop the cylinder advances at the working speed until the Pre-stop 

position is reached. Once the Pre-stop value has been exceeded, the cylinder 

advances up to the stop value, correcting the speed according to the distance from the 

stop value. The greater the distance from the stop value the greater the speed of 

movement. If the stop value is less than the actual value the speed will be negative and 

the cylinder will retract to maintain the programmed stop value. The maximum speed 

during pre-stop can be set with the Pre-stop speed parameter. 

1.2.4 Waiting before return 

When the stop value is reached, a timer is started for the set time with Waiting before 

return. After the time has elapsed, the cylinder return is commanded. Of course, the 

Waiting before return can be set to zero. 

1.2.5 Return 

After the set wait, the cylinder returns to the Rest position with the Return speed. 

1.3 Absolute and relative positions 

The positions referred to the cylinder zero point are referred to as absolute positions. The 

positions referred to the contact point on the manufactured piece are referred to as relative 

positions. Press-Right may set both the absolute and the relative positions. In order to 

measure the contact point on the manufactured piece, Press-Right use the force 

transducer: when the force measured exceeds the Force for contact detection 

value, the relative zero point is set. This “zero point” is called conctact position. The 

conctact position may be monitored by using two limits, a minimum and a maximum value 

(Chapter 0). 



 
 Cylinder absolute zero point 

 Return position (rest position) 

 Relative zero point (contact position) 

 

Figure 1 

The accuracy of the conctact position measured with the load cell may not be increased. It 

depends on the cylinder speed and, in particular, on the type of piece to be manufactured. 

During the shrink-fitting operations, the two pieces show chamfered edges; as a result, the 

conctact position varies also based on the chamfer and the force used to position a piece 

into the other. 

1.4 Control of position-force curve 

Press-Right enjoys different functions. The curve monitoring is performed by a tolerance 

range (chapter 6) and its limits (chapter 0). The limits are the following: minimum and 

maximum force, minimum and maximum position; they can be set or excluded and they 

monitor the maximum value obtained during the production. If the position reached does 

not exceed the minimum position and/or exceeds the maximum position, the piece is 

rejected. At the same time, if the maximum force reached does not exceed the minimum 

force and/or does exceed the maximum force, the piece is rejected. 

From a theoretical point of view there is an ideal curve that may be obtained by 

manufacturing perfect pieces (in practice a sample curve may be obtained by carefully 

manufacturing selected pieces). Any geometric tolerance or difference in materials result 

in a curve that is different from the ideal curve. In practice, there is a tolerance range 

around the sample curve such that, if the curve obtained from the current process does not 



stay inside such range, the piece is classified as scrap. The piece is good only if the 

analysis of the minimum/maximum limits and the tolerance range have a positive result. 

Press-Right also monitors the cylinder return at the end of the production process. Such 

return may result from the exertion of a specific force (stop force) or at a specific position 

(final position). It is possible to set both force and position stop values at the same time; in 

this case the first value to be entered will govern the cylinder return. By changing the value 

of the configuration, it is also possible to command the cylinder return when the curve is off 

the tolerance range. It is always possible to have the unit return by pressing the key on the 

 keypad (stopping the operation). 



2 Installation of Press-Right 

For the installation of the device on the machine, please refer to the specific manual. 



3 Getting started 

This chapter provides information on how to set up basic operations and using the Press-

Right device. 

To better describe the operations, run practical tests.  

 
Figure 2 

To turn the device on use the key on the rear side. When it is pressed, after a few 

seconds, the display turns on and the graph appears. 

3.1 The keyboard of Press-Right 

If you press the menu key, the items that make up the main menu are displayed. To select 

a menu item, it is possible to move with the arrow keys and press enter  or you can 

directly touch the item itself. 

The button  cancels the operations and allows you to return to the main screen. 

3.2 First approach 

To become familiar with the press it is possible to perform a series of manual movements. 

To do this, proceed as follows: 

• press the menu key 

• press the item TOOLS 

• press the item MANUAL CYLINDER MOVEMENT 

• press the ENABLE BUTTONS item 

With the keys  the cylinder can be moved.  

Note: out of the nominal stroke of the cylinder, manual movement is performed at 

minimum speed. 

3.3 Create a job 

The set of cylinder movement and curve control parameters will be called job. 



To create a job: 

• press the menu key 

• press the Jobs management item  

• press the Create a new job item.  

• Enter the name that identifies the job (example TEST 1) and press the enter key. 

3.4 Set the movement 

Note: in the rest of this manual, when it is indicated, for example, to select the command 

Jobs management > Create a new job, you intend to press the menu key then press the 

item Jobs management and finally press the item Create a new job. 

Once the work has been created, it is necessary to define how the cylinder should move. 

The motion profile parameters can be found in Edit job > Movement management. 

Before proceeding, check that there is at least 50 mm of free cylinder stroke. 

Enter the following values: 

Final position =50 mm 

End approach position = 40 mm 

Working speed = 2 mm/s 

Approach speed = 20 mm/s 

Return speed = 50 mm/s 

By pressing the start command of the machine, if the cylinder is further forward than the 

rest position, the cylinder will return to the rest position, on the contrary, if it is already in 

the rest position or further back, the complete programmed cycle will be carried out. Then 

it will advance to the quota of 40 mm at a speed equal to 20 mm/s, from the height of 40 

mm at the share of 50 mm it will advance with a speed of 2 mm/s. Reached the quota of 

50 mm, the return to the rest position will be started with a speed of 50 mm/s. 

3.5 Set the view 

The central part of the display is occupied by the position-force graph. The full-scale 

values can be changed using the commands in the Edit job > Graph setup menu. 

3.6 The main menu 

Note: Some menu items are not visible if not necessary. 

The main menu is the first displayed by pressing the menu key.  

The item of the main menu Job management allows the choice of the job to be 

performed, the creation of a new job or the deletion of the job in use. 

The Edit job and Job property item allows the modification of all the parameters of the 

job in use. See chapter4. 

The Edit phase item is visible when the job is divided into several phases. It allows the 

modification of all the parameters of the displayed phase. 



The Show measured values item displays the values measured during the last cycle. 

The Tools allows the modification of the instrument configuration and the possibility to 

move the cylinder manually. 

The item Piece counter is used to reset the counter of processed pieces. 

The item Part number allows you to enter the identification number of the piece being 

processed. 

3.6.1 The special functions of keys in the main menu 

On the main screen, the key  displays the cursor to measure the force at a certain point 

on the curve. To move the cursor, use the arrow keys  .  

If menus are not displayed, press the  key to display the main menu together with the 

windows showing the special key functions. 

 



4 The JOB 

The Press-Right stores all the settings (parameters, band and counters) relating to the 

various jobs in an internal memory. Each group of settings is called “Job”. Each job has its 

own name. 

In the main menu there is the item Jobs management. Through this menu it is possible to 

choose a job among those present, create a new one, or delete the job in use. 

4.1 Create a new job 

To create a new job, use the Jobs management > Create a new job command and give 

it a name. As a name you can use the number of the design, the name of the customer or 

whatever you prefer to be able to easily identify it. 

When you create a new job, you are asked if you want to make a copy of the job currently 

in use. If you choose to copy the current job, the parameters of the current job will be 

duplicated and will remain unchanged. In the other case the new one will be empty. 

After creating the job, you can set the parameters, options and the range. 

4.2 Selecting a job 

In the Job management menu, there is the Change job command. When this command 

is selected, the list of available jobs is displayed. The date and time the job was last 

modified is shown next to the name. 

If the list is very long, you can press the numeric keys to jump from one point to another in 

the list. 

4.3 Change the name of the job 

To change the name of a job, you must first select it. Once you have selected the job you 

want to rename, you can use the Job management > Edit job > Name of job command. 

4.4 Copy a job 

To copy a job, select the job to be copied as shown in paragraph 4.2. Once the job to be 

copied is selected, create a new job by using the Jobs management > Create a new job 

command and answer YES to the copy question. 

4.5 Delete a job 

In the Jobs management menu, the Delete job command is displayed. This command 

allows to delete the current job permanently.  

4.6 Edit a job 

The Job management > Edit job menu allows to change all the parameters entered for 

the job. 

In the jobs, parameters set to zero will be ignored by the device. 



4.7 Job counters 

Each job has a piece counter. To access the counter options, select the Job management 

> Edit job > Scheduling menu. 

In this menu it is possible to reset the counter of the pieces or choose a maximum number 

of other pieces to block the instrument. 

4.8 Managing the automatic selection of jobs as an external user 

When the automatic job selection is activated, the Press-Right prepares the selectable 

jobs. These jobs are initially empty. To make an empty job usable, access the Job 

management> Change job menu and press enter on the desired job, at this point it will be 

possible to choose the name of the job. 

4.9 The graph 

In the EDIT JOB menu, the SET GRAPH item is available, allowing for the editing of the graph 

axes. Note that it is not possible to edit these values and fully or partly hide the range. 

As shown in both figures, it is possible to select the following values: 

GRAPH ORIGIN 

It is the original value of the horizontal axis of the dimensions, this parameter allows 

you to hide all the uninteresting run, such as the approach run. If relative dimensions 

are used, the origin should normally be set equal to zero. 

SCALE POSITION 

The full scale of the dimensions indicates the maximum travel that is displayed in the 

graph. 

END SCALE FORCE 

The full scale of the forces indicates the maximum force that is displayed in the graph. 

4.9.1 How to set the graph 

After the execution of a part, the measured values can be displayed. From these it is 

possible to obtain the values of the axes of the graph. 

As the origin of the graph, enter a value slightly lower than the measured start elevation. 

As full scale of the dimensions, enter a value higher than the measured quota reached. 

As the full scale of the forces choose the value greater than the measured force reached. 

4.10 Rejected options and management 

In addition to the generic options, there are options for waste management, options for 

additional test signals, options for machines with multiple force transducers and options for 

equipment control. All these options are accessible from the menu CONFIGURE 

OPERATION. 

4.11 Phases management 

It is possible to associate several processing steps to a single job. They can be considered 

as “sub-works” that contribute to the completion of a more complex process (for example 

the insertion of a bearing and a gear on the same shaft). 



To use more phases, it is necessary to enable the execution of the phases in the menu 

Job properties> PHASES MANAGEMENT> enable phases. 

With the keys  it is possible to display the desired phase and modify its parameters 

with the MODIFY PHASE menu. 

The phases will be carried out automatically in sequence. If you want to perform one 

individually out of sequence, select the PHASE TO EXECUTE menu. 

A phase can be repeated several times. 

4.12 Channel management 

Up to six force transducers can be connected to the Press-Right to control as many 

displacement-force curves. While each force transducer detects the force of a channel, the 

position transducer is only one in common to all channels. It is possible to exclude one or 

more channels from the control thanks to the CONFIGURE OPERATION> CHANNEL 

SELECTION menu. 

Below the graph is displayed the strength of only one channel at a time, using the number 

keys from 1 a 6, when the menus are not displayed, it is possible to view the current 

strength of each individual channel. 

To view the curve of some channels it is necessary to press the menu key to display the 

main menu and a numeric key between 1 and 6..  

4.13 Self-verification 

The self-check function is used to periodically check the operation of the machine by 

making sample pieces deliberately prepared out of tolerance. 

This function can be activated from the TOOLS > CONFIGURE > VISIBLE OPTIONS 

menu. 

The execution of the sample pieces can be carried out every time the instrument is turned 

on, every time the job is changed, every time the job is changed, at pre-established times, 

any number of pieces. 

For each single job it is possible to exclude the self-check function. 

4.14 Managing additional controls 

In addition to the curve control, it is possible to connect up to three additional sensors to 

determine if the part is good or bad. In practice, the outcome of the processing can be 

conditioned by the logical state of three inputs. This logical state can be checked at 

various instants of processing. 

For additional control number 1, the Press-Right can also activate an output before 

performing the control and, after a predetermined time, read the input status. 

The TOOLS> CONFIGURE> SIGNAL OPTIONS menu allows the configuration of the 

inputs and the assignment of a descriptive name. 

In the CONFIGURE operation> ADDITIONAL SENSORS menu it is possible to establish 

when and how to carry out the additional checks. 

4.14.1 Additional control options 

The additional control options are as follows: 



It does not measure 

The additional check is not performed. 
Measure at the start 

The additional check is carried out when the instrument receives the START 

command. 
Measure at stop 

The additional check is carried out when the tool wants to command the stop and the 

piece is good. 
Measure at a height 

The additional check is carried out at a fixed altitude. 
Use as an enable 

The signal is checked at the beginning of the work to enable or disable the cycle. 

 



5 Parameters 

Note: in general, the parameters set equal to zero will be ignored by the instrument. 

5.1 Motion management 

Once a new job has been created, the movement of the cylinder must be defined.  

The motion profile parameters are as follows and can be found in the Edit job > 

Movement management menu. 

Final position  

Quota to be reached. 

STOP FORCE 

Force that commands the cylinder to stop before the final position. 

End approach position 

Quota to be reached in rapid advance for approaching the piece. This height must be 

lower than the contact point with the piece. If a force is measured during the approach, 

the system goes into collision alarm. 

REST POSITION 

Return quota finished the pressing cycle. In fact, the cylinder does not necessarily 

have to return to zero position (this item is visible only if the relative option is activated 

in the TOOLS> CONFIGURE> VISIBLE OPTIONS menu). 

WAITING BEFORE RETURN 

In some cases, it may be useful to stop at the end of pressing position for a few 

seconds. 

WORK SPEED 

Speed of the pressing section.  

APPROACH SPEED 

Speed of the rapid feed section for approaching the piece. 

CONTACT SPEED 

Speed used at the end of approach until contact with the piece. If zero is not used. 

RETURN SPEED 

Return speed after pressing at rest level. 

PRE-STOP POSITION 

Pre-stop start quota. If zero is not used. 

PRE-STOP SPEED 

Speed with which the cylinder performs the last section of work starting from the pre-

stop position. If zero is not used. During the pre-stop the cylinder adjusts the speed 

with the measured force value. 

5.2 Limits and thresholds 

The control limits, together with the band, determine the outcome of the work. 
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Maximum force limits, maximum altitude limits, initial altitude limits and checkpoints can be 

set. 

Note: Control limits, set equal to zero, are not used. 

Contact position limits 

They control the contact dimension of the machining. For a piece to be classified as 

good, the measured contact height must be above the minimum contact height limit 

and below the maximum contact height limit. 

Peak position limits 

They check the maximum height reached during processing. For a piece to be 

classified as good, the measured quota reached must be higher than the minimum 

quota reached limit and lower than the maximum reached quota limit. If the minimum 

quota limit reached is not set and the tolerance band is present, the position of the 

band is used as the minimum limit. 

Peak force limits 

They control the force achieved during processing. For a piece to be classified as 

good, the maximum force achieved must be higher than the minimum force limit and 

less than the maximum force limit. 

Force for contact detection 

The start force is the force threshold used to measure the contact height. 

5.2.1 How to choose the limits 

Contact dimension limits allow you to control component sizes even before work begins. 

They can be used to check the dimensions of the pieces to be assembled or to check that 

there are all the details necessary for processing. 

The choice of the limits of the height values and of the force reached depend on the type 

of machining. In general you can follow this guide: 

Limits with machining with mechanical stop 

When there is a mechanical stop the press will always reach either the stop force or the 

maximum force it can exert. In this case the minimum reached force limit can be used 

simply to control the achievement of the stop force. The maximum height limit reached can 

be used to check that the maximum force that the piece can withstand is never exceeded. 

In this process, to check the effective force required, the band or check points are 

necessarily used. 

The reached dimension limits are used to verify that the dimensions of the assembly, after 

machining, are in tolerance. 
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Limits with machining without mechanical stop 

In this case the force limits are not very useful other than to check that the force does not 

exceed the maximum force supported by the workpiece. The force check must be 

performed with the band or check points. 

Dimension limits can be used to verify that the final assembly size is actually what is 

required. 

Limits for bending and breaking tests 

In bending tests the force limits are used simply to check the force that has been applied 

while the height limits are used to check the measured bending. 

In breaking tests, force limits are used to verify the force that was required to break the 

piece. 

5.3 Check points 

Checkpoints are additional tools for work control. It is possible to define up to five check 

points according to this type: 

Force control at a certain position (Check force) 

Position control at a certain force (Check position) 

Software filter of the measured force (Digital force filter) 

Measurement of the minimum and maximum force value within a height range and control 

of the maximum delta (Min/max measurement). 

Measurement and control of the slope of the curve within a height interval (Check the force 

variation) 

5.4 Job options 

The following job options can be changed with the CONFIGURE OPERATIONS> 

OPTIONS command. 

Use relative odds 

By activating this option, relative dimensions are used instead of absolute ones 

(chapter 1.3). 

Ask for the part number 

By activating this option, before the execution of each piece you are asked to enter a 

numeric code that identifies the piece itself. This code is used by the WinScope 

program for archiving the curve and measured values. 

Ignore consent 

It does not condition the start to the logical state of these inputs (if configured). 

Exclude PRESS SELF-CHECK 

Disable the self-check of the press in the job. 

Exclude SELF-CHECK "TEST 1 " 

Disable the self-check of the additional control in the job. 

Save curves good pieces 

Saves the curves of the good pieces on the SD memory. 

Save scrap curves 

Saves the curves of the rejected pieces on the SD memory. 



 20 

Do not use waste basket 

Disable the control of the waste basket in the job. 
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6 The tolerance bande 

The band is used to control the curve and consequently to control the quality of the piece. 

The band consists of two lines called the upper edge and lower edge. 

For the piece to be classified as good the points representing the curve cannot be above 

the top edge, and they cannot be below the bottom edge. 

The figure shows a curve relating to a good piece, as it is between the two edges of the 

band. 

 
Figure 3 

Each border is made up of a sequence of stitches joined by segments.  

6.1 Create the bande 

To modify the band, use the Edit job > Tollerance band command. When moving 

stitches, be careful not to reverse the top and bottom edges. 

The RESET key can be used to end the modification of the band. 

The modification of the band is carried out by moving the points that determine the two 

edges. When modifying the band, only one point of one of the two edges is highlighted, 

this point is the active one, that is the one that can be moved using the keys . 

It is possible to change the active point with the commands “select previous point” and 

“select next point”. To activate the points of the other edge, press the “select the other 

edge” command. The force and elevation of the active point are displayed below the 

graph. 

You can add a point by dividing the segment that follows the active point in two. To do this, 

press the "add point" command. 

It is possible to delete the active point with the “delete point” command. 

When using the arrow keys, it is possible to change the pitch by pressing the “change shift 

pitch” command.  

6.2 Delete the range 

In order to delete a range, use the command Edit job > Tollerance band > Delete band.  
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7 Rejected piece 

When a scrap piece is detected, the tool stops, preventing the execution of new pieces. In 

the standard configuration, to re-enable the instrument, RESET must be performed. 

If the work has several phases, the Press-Right can request confirmation of the rejection. 

7.1 Causes rejection 

A piece can be good or bad. The instrument can manage two reject signals to classify the 

rejects. The rejection can be caused by one or more different causes. The following list 

shows all the possible causes of rejection. 
MAXIMUM FORCE EXCEEDED 

The maximum force achieved has exceeded the maximum force limit. The maximum 

force reached may not coincide with the force of the last point of the curve. 
MINIMUM FORCE NOT REACHED 

The maximum force reached did not reach the minimum force limit. The maximum 

force reached may not coincide with the force of the last point of the curve. 
UNDER THE BOTTOM EDGE 

The curve has passed under the lower edge of the band. 
ABOVE THE TOP EDGE 

The curve has passed over the upper edge of the band. 
CANCELED FROM KEYBOARD 

The execution of the job was interrupted by the operator pressing the key . 

EXECUTION ABORTED 

The START input was removed during the execution of the job. It is usually caused by 

the intervention of emergencies. 
TIME OUT 

The execution of the work took too long.  
"ADDITIONAL" BEYOND THE MAXIMUM 

The value of the additional transducer is higher than the additional maximum limit. 
"ADDITIONAL" BELOW THE MINIMUM 

The value of the additional transducer is less than the additional minimum limit. 
"ADDITIONAL" CONTROL 

The additional check caused the rejection. 
MAXIMUM QUOTA EXCEEDED 

The maximum altitude reached has exceeded the maximum altitude limit. The 

maximum height reached may not coincide with the height of the last point of the 

curve. 
MINIMUM QUOTA NOT REACHED 

The maximum quota reached has not reached the minimum quota limit or has not 

reached the range. The maximum height reached may not coincide with the height of 

the last point of the curve. 
HIGH STARTING ALTITUDE 

The value of the starting altitude is higher than the maximum limit of the starting 

altitude. 
LOW STARTING ALTITUDE 

The value of the starting altitude is lower than the minimum limit of the starting altitude. 
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MAXIMUM LIMIT CHECK POINT 

The value measured in the checkpoint is above the maximum value. 
MINIMUM CHECK POINT LIMIT 

The value measured in the checkpoint is below the minimum value. 

7.2 Rejected management 

For each discard cause, it is possible to tell the device how to classify the piece or how to 

behave. For the configuration, choose the discard cause desired from the menu that 

appears by selecting JOBS MANAGEMENT > EDIT JOB > CHANGE JOB > SCRAP AND 

MONITORING OPTIONS > SCRAP MANAGEMENT. Once the discard cause is selected, the 

following sub-menus appear: 

CLASS  

For each discard cause, it may be classified as regular or special. This allow to classify 

scrap materials and sort them. For instance, it is possible to sort reusable scraps from 

not recyclable materials. When a special scrap is detected, Press-Right activates the 

second scrap port ad count the piece separately. This way, it is possible to know 

whether the pieces are rejected by mistake by the operator. 

DISCARD PROCEDURE 

For each discard cause, it is possible to shutdown the press as soon as it detects the 

discard cause, stop the press being operated and/or enter the unlock password. 

The first item of the discard cause list is ALL, by selecting this item, the choices to be made 

will be applied to all the whole cause list. 
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8 The Tools menu 

Press-Right configuration is carried out through the TOOLS menu. When the Press-Right 

is supplied already connected to the machine, it is not necessary to perform the 

configuration. 

In this menu there are the following submenus: 

DISPLAY MANAGEMENT 

It allows to change visualization (chapter 0). 

MAINTENANCE 

It allows to set a interval for maintenance and with the command Move to 

lubrification position, the cylinder descends to the greasing level. Make sure 

the cylinder is free to move forward. 

MANUAL CYLINDER MOTION 

It allows to move manually the cylinder (chapter 8.3). 

ADVANCED OPTIONS 

It allows to set up the device and caliber the transducer (chapter Errore. L'origine 

riferimento non è stata trovata.). 

8.1 Display options  

The display options change the display. 
DO NOT DISPLAY THE MEASURED VALUES  

At the end of the acquisition, normally, a window is shown that contains the measured 

values and the result of the processing, by activating this option the window will not 

appear automatically, but you will have to manually choose the MEASURED VALUES 

command in the main menu. 
OVERLAP CURVES 

By activating this option, all the curves will be superimposed on each other creating a 

strip that represents the dispersion of the forces. 

8.2 Counters and self-verification 

Press-Right can be set up so that, at fixed intervals, the tool must be replaced, the 

transducers calibrated and the self-verification system monitored. The self-verification 

function is described in chapter 4.13. 

8.3 Manual moving 

Allows manual handling of the press. 

ENABLE MANUAL MOVEMENT 

With this command you can use the arrow buttons to move the cylinder. In the manual 

movement the first stretch occurs very slowly, then the speed increases. If the cylinder 

is under stress the speed will be limited. 

GO TO POSITION 

With this command it is possible to bring the cylinder to a known position. 

DESCENT TO TOUCH 
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With this command the cylinder descends until it touches the piece. The feed speed 

and contact force is set in the cylinder configuration menu. 
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9 Intrument configuration 

In general, when the Press-Right is supplied already connected to the machine, it is not 

necessary to configure it. 

Thanks to the many configuration options, the Press-Right can adapt to your needs.  

To configure the Press-Right, access the TOOLS> CONFIGURE menu. 

In this menu you will find the following items: 
GENERAL OPTIONS  

It allows to configure the Press-Right according to the type of press connected and to 

activate some functions. See the chapter0. 
ELECTRICAL CONNECTIONS 

Allows setting the function of each input and each output. 
CONFIGURE CYLINDER  

Allows cylinder configuration. Some parameters are protected by a particular 

password which must be requested from Alfamatic. 
SELECTABLE WORKS 

The work to be performed can be chosen by means of a combination of the inputs or 

by means of a command sent via serial communication. In this case it is necessary to 

indicate how many jobs can be selected from the outside. 
AUTOMATIC JOB SELECTION 

These options determine how the Press-Right has to manage the selection of the job 

and the phases, see the chapter 9.2. 
NETWORK AND CLOCK 

Allows definition of the machine name, network settings and system clock. 
VISIBLE OPTIONS 

Allows you to indicate which options should be visible. 

9.1 General options 

Some general options depend on the type of press connected, others activate particular 

functions. The general options are accessible from the TOOLS> CONFIGURE> 

GENERAL OPTIONS menu. 
TURN OFF RED WITH RESET 

Normally when a scrap piece is machined the red light is made to flash until the reset 

is pressed. At this point the red light remains on steady. By activating this option the 

red light will go out once the reset has been given. 
ACCEPT STOP FROM EXTERNAL SIGNAL 

Normally it is the Press-Right that stops the acquisition and stops the press. If the 

START signal is removed during the acquisition, the Press-Right stops the press and a 

reject signal due to unexpected interruption. By activating this option, when the START 

input is deactivated, the Press-Right ends the acquisition and checks the curve marks 

forcing the piece as waste. 
WAITING TO SAVE COMPUTER DATA 

By activating this option, the Press-Right does not allow the machining of the pieces if 

it is not connected with the WinScope program. This option is useful if you want to 

archive all the workings in the computer memory. 
IT ONLY COUNTS IF YOU TOUCH THE PIECE 
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By activating this option, the Press-Right will not increase the piece counter if it has 

not measured a starting position, that is, if it has not met the piece. 
DIFFERENT WASTE CLASS IN EVERY JOB 

By activating this option, each job has a different waste management (chapter 7). 

9.2 Automatic selection of jobs 

These options change the method used by the tool for automatic selection of jobs and 

phases. The options are accessible from the TOOLS> CONFIGURE menu. 
ALLOW PHASE CHOICE WITHOUT PASSWORD 

By activating this option, the operator can perform a phase out of sequence without 

having to enter the password. 
ASK IF REPEAT THE WASTE PHASE 

By activating this option in the event of a reject phase, the operator can repeat the 

execution of the same phase. 
RUN THE CHOSEN JOB ONLY ONCE 

When the selection of jobs is external, by activating this option, the operator can 

choose a job other than the one selected. Once the execution of a piece with this 

chosen job is finished, the tool will reselect the correct job. 
ALLOW JOB CHOICE WITHOUT PASSWORD 

By activating this option, the operator can choose a job other than the one selected 

externally without having to enter the password. 
USE DIFFERENT CELL FOR EVERY PHASE 

If multiple load cells are connected to the instrument, activating this option will use a 

different cell for each phase. This option allows you to connect up to four identical 

presses that work in sequence one after the other to a single Press-Right. 

9.3 Phase repetetion 

A phase can be repeated several times. Upon completion of the job, you can see a 

confirmation message. 

To enable the phase repetition function, activate the option in the menu: TOOLS> VISIBLE 

OPTIONS> CHOICE OF PHASE REPETITIONS NUMBER. 

To enable the possibility of confirming the piece, activate the option in the menu: TOOLS> 

VISIBLE OPTIONS> ASK FOR CONFIRMATION AT THE END OF THE PIECE. 

To indicate how many times a phase must be repeated, enter the number of repetitions in 

the menu: CONFIGURE OPERATION> REPEAT PHASE. 

To reset the repetition counter during processing, touch the counter shown on the 

instrument display and confirm. 
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10 Diagnosis 

The diagnostic function enables: the visualization of the input status, the visualization and 

the forcing of outputs, the calibration of the transducers. 

Given the complexity of these operations, we recommend the use of qualified personnel. 

The activated inputs and outputs that are highlighted with a black rectangle. 

To force the outputs, move the cursor with the   keys on the desired output and 

press . In order to force an output, enter the hardware password. 

The diagnostics window also displays the firmware version of the tool. 

Note: During diagnostics, the tool does not work. To monitor the input and output status 

while the tool is running, press the "dot" key in the main display (off the menu). 

10.1 Firmware version 

To find out the firmware version of the instrument, enter diagnosis and choose help 

TOOLS> DIAGNOSIS. 
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11 Special configurations 

On request it is possible to have special configurations. 

11.1 Additional force transducer 

It is possible to provide the instrument with a small force transducer for greater precision in 

processes that require reduced forces. The Alfamatic pressure transducer has been 

designed to withstand the maximum force that can be exerted by the cylinder. 

11.1.1 Configuration of additional force transducer 

To be able to connect an additional force transducer, the instrument must have the inputs 

for two load cells. In addition, a sensor is required that remains active if the smaller load 

cell is not mounted under the press. In this way the instrument can know when to use the 

normal load cell. 

The sensor that feels the absence of the smallest load cell must be connected to an input 

configured as TEST SIGNAL 3 in the TOOLS menu> ADVANCED OPTIONS> 

CONFIGURE> INPUTS AND OUTPUTS SETUP> INPUTS. 

The connection of the smallest load cell must be made to terminal block X22. 

To configure a second load cell, activate channels 1 and 2 from the TOOLS menu> 

ADVANCED OPTIONS> CONFIGURE> CHANNEL PHASE JOBS> CHANNEL NUMBER. 

Once the two channels have been activated, the Additional cell option must be activated 

for reduced forces in the TOOLS menu> ADVANCED OPTIONS> CONFIGURE> 

CHANNEL PHASE JOBS> OPTIONS. 

11.1.2 Use of additional force transducer 

The work to use the additional force transducer must have the option as Use transducer 

for reduced force in the menu WORK MANAGEMENT> EDIT THE JOB> CHANGE 

WORK> OPTIONS AND WASTE> OPTIONS. 

11.2 Tool recognition 

Up to three RFID transceivers can be connected to the instrument to re-recognize press-

mounted equipment. 

Thanks to the recognition of the equipment it is possible to prevent the operation of the 

press if the equipment is not that provided by the work, or it is possible to have the work 

selected selected based on the equipment fitted or it is still possible to have the phase of 

the work in operation automatically selected of the tool in use. 
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12 Password 

Press-Right can store a list of users with their identification codes. 

The identification code is a four or five-digit code. 

The last three digits are never displayed, and serve as a password. 

Each user can define permissions, that is, the functions that can be accessed to. 

There is a special password that allows access to all functions and user management. 

This hardware configuration password, when the tool is new, is 9724. 

The passwords can be changed: to order to do this, it is necessary to know the old 

password. 

When you enter a user name that is authorized to change jobs, the display shows the  

icon. 

When you enter a user name that is authorized to change setup, the display shows the  

icon. 

By selecting the REACTIVATE PASSWORD item, the icons will disappear and the user code will 

be requested again to enter the adjustment values. 

PASSWORD-PROTECTED FUNCTIONS 

This sub-menu defines which tool functions are only accessible by entering the user code. The 

user who enters his or her code can only access if the permits are enabled. 

USER MANAGEMENT 

In the user management menu, users can be added or deleted. When a user is added, choose a 

name, a code (four or five digits) and the permissions granted to the new user. The code must 

have a unique pair of four and five digits. 
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13  Computer connection 

Press-Right can be connected to a computer. It is possible to connect the tool to the 

computer via USB  or the Ethernet port (optional). 

The tool is provided together with the Winscope software, enhancing the tool capabilities. 

13.1 Connection via USB port 

If you are using the USB connection you must use a standard USB type A / B cable.  

When the Press-Right is connected to the computer for the first time, the operating system 

will search for drivers to properly manage the device. For this reason the computer must 

have access to the internet at the first connection. 

Once the drivers have been installed, the instrument will automatically be displayed in the 

WinScope Connection menu. 

13.3 Connection via LAN port (Ethernet) 

In order to use the Ethernet port, a unique IP address must first be assigned to the 

instrument. To do this, you need the Press-Right Setup software or access the TOOLS 

menu> ADVANCED OPTIONS> NETWORK NAME AND CLOCK SETUP> ETHERNET 

CONFIGURE. After assigning an IP address to the instrument, it is necessary to add it to 

the list of ports that can be used in WinScope through the relative Preferences command 

in the File menu. 

13.3.1 Assign IP address to the instrument 

Install and start the Press-Right Setup program; Select the Set IP address command in the 

File menu. 
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Select the tool to which the IP address is to be assigned in the list that is shown. 

 

If the list is empty, monitor the status of the firewall in your computer, if any. The firewall 

can be disabled in the Windows monitor Panel. 

If you cannot find the tool to be set up, just turn it off, reload the list and see which one is 

missing. 

After choosing the tool, the following window appears, where an IP address can be 

assigned: 
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14 Field bus 

The Press-Right instrument can communicate via Modbus TCP field buses (standard), 

PROFINET or EtherNet/IP (optional). 

14.1 Organization 

The instrument has a list of registers that can be read or written via fieldbus 

communication. 

Each register has an address. From the field bus it is possible to access the registers by 

indicating the address of the same. 

With the PROFINET and EtherNet / IP buses, you also have direct access to 11 registers 

for reading and 11 registers for writing. It is possible to decide, by filling in a table, which 

information should contain these direct access registers. 

14.2 Status and Control 

The register at address 1STATUS_WORD_INPLC contains the instrument status bits. 

The register at address 24 CONTROL_WORD_OUTPLC allows the command of the 

instrument. 

When a command (other than zero) is written, the CMD_BUSY bit of the status register is 

raised to indicate that the command has been received by the instrument. 

If the command is valid, the RUN bit of the status register is raised. 

If the command is not valid, the ERROR bit of the status register is raised. 

At the end of the execution of the command, the RUN bit is reset and the COMPLETED bit 

activated. 

The CMD_BUSY bit is cleared if zero has been written as a command and if execution is 

finished. 

The COMPLETED and ERROR bits are cleared when a new (non-zero) command is 

written. 

14.3 PROFINET and EtherNet/IP 

Through these field buses, you have access to 16 variables in input and 16 variables in 

output. 

Through the first four input variables (CTRL_INPLC, SUBINDEX_INPLC, INDEX_INPLC, 

PV_INPLC) and output (CTRL_OUTPLC, SUBINDEX_OUTPLC, INDEX_OUTPLC, 

PV_OUTPLC) it is possible to have read and write access (if allowed) through address / 

data to all instrument parameters . 

The STATUS_WORD_INPLC input word contains the instrument status bits (register 1). 

The CONTROL_WORD_OUTPLC output word contains the commands to be supplied to 

the instrument (register 24). 

The content of 11 words in input (VAR1_INPLC ... VAR11_INPLC) and 11 words in output 

(VAR1_OUTPLC ... VAR11_OUTPLC) can be configured by the user through the “Press-

Right Setup” software. 
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The default content of these words is the following: 

 

14.3.1 Access via address / data 

14.3.1.1 Initialization 

Load the value 0x00 into CTRL_OUTPLC 

Wait for CTRL_INPLC to contain 0x00 

14.3.1.2 Reading a 16-bit register 

Load the register address into INDEX_OUTPLC 

Load the value 0x40 into CTRL_OUTPLC 

Wait for CTRL_INPLC to contain 0x10 

Read the value from PV_INPPLC 

Load the value 0x00 into CTRL_OUTPLC 

Wait for CTRL_INPLC to contain 0x00 

14.3.1.3 Reading a 32-bit register 

Load the register address into INDEX_OUTPLC 

Load the value 0x10 in CTRL_OUTPLC 

Wait for CTRL_INPLC to contain 0x20 

Read the value from PV_INPPLC 

Load the value 0x00 into CTRL_OUTPLC 

Wait for CTRL_INPLC to contain 0x00 

14.3.1.4 Writing a 16-bit register 

Load the register address into INDEX_OUTPLC 
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Load the value to be written into PV_OUTPLC 

Load the value 0x20 into CTRL_OUTPLC 

Wait for CTRL_INPLC to contain 0x10 

In case of an error CTRL_INPLC will contain 0x70 

Load the value 0x00 into CTRL_OUTPLC 

Wait for CTRL_INPLC to contain 0x00 

14.3.1.5 Writing a 32-bit register 

Load the register address into INDEX_OUTPLC 

Load the value to be written into PV_OUTPLC 

Load the value 0x30 into CTRL_OUTPLC 

Wait for CTRL_INPLC to contain 0x20 

In case of an error CTRL_INPLC will contain 0x70 

Load the value 0x00 into CTRL_OUTPLC 

Wait for CTRL_INPLC to contain 0x00 

14.3.2 PROFINET interface 

To install the GSD file in the library, select Tools> Device Description File Management. 

You can find it in the library under Additional field devices> PROFINET IO> General> 

Alfamatic> PressRight. 

The name and address of the device is set by TIA: 

Open the TIA, under "Online access" select "Update accessible nodes". It should appear 

just below with the name CompactCom 40 PIR. 

Open the device and in the "Functions" branch you will find set IP and set Name. 

A new module is found automatically if it has the same IP address and name. 
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15 Organization of registers 

15.1 Command execution 

By writing in the CONTROL_WORD_OUTPLC the press is controlled. 

The command must be written until the STATUS_WORD_INPLC command busy bit 

becomes high; at this point it is necessary to write zero in CONTROL_WORD_OUTPLC. 

Regardless of whether the command involves a movement or not, as long as the 

command is present, bit 11 of STATUS_WORD_INPLC will remain high. 

15.2 Behavior of the status register 

Below is the behavior of the status bits under the most common conditions: 

In this chapter the Busy bit is not indicated because it always behaves the same way: High 

when a command is received, low when the zero command is received. 

The Result OK and KO bits are activated at the end of the phase and must be reset with 

command 16 or 17. 

If the operator stops the cylinder by pressing the reset key or if a malfunction occurs, the 

Fault bit is activated instead of the Completed bit and the Ready bit is not activated. 

The fault is reset with command 1. 

Stop at the resting altitude ready to go: 

Ready + Rest position + (Zero Position) 

Starting the phase with command 10: 

As soon as the movement begins: 

Running + Execute 

At the end of the movement: 

Ready + Rest Position or Zero Position + Completed + (Rest position and / or Zero 

Position if with automatic return) 

Return to rest position or to zero with command 12 or 11: 

As soon as the movement begins: 

Running + Execute 

At the end of the movement: 

Ready + Rest Position or Zero Position + Completed + Rest position and / or Zero Position 

15.2.1 Note 

Rest Positionit behaves differently depending on whether an input is configured as “Start 

return” or not. With a “Start return” input, the Rest Position bit is active if it is at rest 

position. Without a “Start return” input, the Rest Position bit is active if it is at rest position 

or further behind it. 

15.3 Strings 

The strings are made up of single 8-bit ASCII characters terminated by the code 0x00. 

It is advisable to avoid accented letters. 

Since each register has 16 bits, there are two characters in a single register. 
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The high byte of the register contains the first character of the pair. 

The low byte of the register contains the second character of the pair. 

Below is an example of reading the name of the job that we assume to be "Job 2": 

ASCII Codes: 

J 0x4A 

or 0x6F 

b 0x62 

space 0x20 

2 0x32 

The following registers will have the following content: 

register 1000 will contain “Jo” 0x4A6F 

register 1001 will contain “b” 0x6220 

register 1002 will contain "2 " 0x3200 

15.4 Table of registers 

Some commands use, for their function, the text contained in the register at address 45. 

For example, to use the commands 2 (select job by text code), 3 (select job by name) and 

4 (set the part number), the text must be uploaded to address 45 before executing the 

command. 

Each job has a name, in addition to this it can have alphanumeric identification codes 

(barcode) and an index. 

The current job name is listed at 1000. 

The index of the job allows the selection through a simple numerical value. For selection 

by index, the index must be written to register 90. 

Table: 
 

Name Description Type Addr Access 

Dummy   0  

Status and Flags Bit 0 (BYTEH.0) Ready* 
Bit 1 (BYTEH.1) Zero Position 
Bit 2 (BYTEH.2) Rest Position 
Bit 3 (BYTEH.3) Fault 
Bit 4 (BYTEH.4) Running 
Bit 6 (BYTEH.6) Start enabled 
Bit 7 (BYTEH.7) New Part Number 
Bit 9 (BYTEL.1) Result OK (from version 2.30 to 
reset use control word = 16 or 17) 
Bit 10 (BYTEL.2) Result KO (from version 2.30 to 
reset use control word = 16 or 17) 
Field bus status bits: 
Bit 11 (BYTEL.3) Command BUSY 
Bit 12 (BYTEL.4) JOG mode 
Bit 13 (BYTEL.5) Command ERROR 
Bit 14 (BYTEL.6) Command COMPLETED 
Bit 15 (BYTEL.7) Command EXECUTE 

UINT16 1 Read only 

PositionAct Current position of the cylinder INT32 2 Read only 

SupplAct Current value of additional transducer INT32 4 Read only 
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ForceAct Current force INT32 6 Read only 

Control Word 0 no command 
Write 1 to reset fault 
Write 2 to select job by text code (&45) 
Write 3 to select job by name (&45) 
Write 4 to set the part number (&45) 
Write 5 to save data on persistent memory 
Write 7 to reset flags (from version 1.58) 
Write 8 to delete the curves in memory 
Write 9 to Re-read registers (from version 1.86) 
Write 10 to start phase 
Write 11 to start to position zero (from version 

1.58) 
Write 12 to start to rest position (from version 

1.58) 
Write 13 to start touching (from version 1.58) 
Write 14 to disable driver (from version 1.77) 
Write 16 to enable start command 
Write 17 to disable start command 
Write 18 to reset job pieces counters 
Write 20 to stop movement 
Write 21 to start basic movement 
Write 24 to enable Jog (from version 1.58) 
Write 25 to disable Jog (from version 1.58) 
Write 26 to Stop Jog Mov (from version 1.58) 
Write 27 to Start Jog+ (from version 1.58) 
Write 28 to Start Jog- (from version 1.58) 
Write 30 to Set new Order number (&45) (from 

version 1.92) 
Write 32 to Reset rejected (from version 2.21) 

UINT16 24 Write 

Position1 Target position for basic movement UINT16 32 Write/read 

Speed1 Speed for basic movement UINT16 33 Write/read 

ToolA Tool A ID UINT16 42 Read only 

ToolB Tool B ID UINT16 43 Read only 

ToolC Tool C ID UINT16 44 Read only 

StringBuffer Text buffer STRING 24L 45 Write/read 

OrderNum Order number STRING 24L 62 Write/read 

JobIndex Job number 
The first job is number 1 

UINT16 90 Write/read 

PhaseAct Phase number 
The first phase is number 1 

UINT16 91 Write/read 

PhaseValue Phase values UINT16 92 Write/read 

MainCounter Main counter UINT32 95 Read only 

JobNumOK Number of good pieces (to reset use control word 
= 18) 

UINT32 97 Read only 
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JobNumNOK Number of rejected pieces (to reset use control 
word = 18) 

UINT32 99 Read only 

MaxNumOK Maximum number of good pieces UINT32 101 Write/read 

PartNumber Code STRING 28L 
Read only 

103 Read only 

 

InstrumentName Name of the instrument STRING 15L 200 Read only 

 

DecimalsY Number of decimals digit of force values UINT16 207 Read only 

DecimalsX Number of decimals digit of position values UINT16 209 Read only 

DecimalsP Number of decimals digit of probe values UINT16 211 Read only 

InstrumentName Name of the instrument STRING 24L 213 Read only 

JobName Name of current job STRING 14L 1000 Read only 

StopPosition Stop position UINT16 1014 Write/read 

StopForce Stop force UINT16 1015 Write/read 

EndApproachPos End position for fast approach  UINT16 1016 Write/read 

RestPosition Rest position UINT16 1017 Write/read 

ApproachSpeed Speed for fast approach UINT16 1018 Write/read 

TouchSpeed Speed for contact after approach UINT16 1019 Write/read 

WorkSpeed Main working speed  UINT16 1020 Write/read 

ReturnSpeed Return speed UINT16 1021 Write/read 

PreStopPos Pre-stop start position UINT16 1022 Write/read 

PreStopSpeed Pre-stop speed UINT16 1023 Write/read 

StopDelay Delay before return (from version 1.86) UINT16 1024 Write/read 

ContactForce Force for contact sens (from version 1.94) UINT16 1025 Write/read 

PeakPosMin Value minimum of reached position UINT16 1027 Write/read 

PeakPosMax Value maximum of reached position UINT16 1028 Write/read 
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PeakForceMin Value minimum of reached force UINT16 1029 Write/read 

PeakForceMax Value maximum of reached force UINT16 1030 Write/read 

InitPosMin Value minimum of conctact position UINT16 1031 Write/read 

InitPosMax Value maximum of conctact position UINT16 1032 Write/read 

CP1par1 First value of check point 1 UINT16 1033 Write/read 

CP1par2 Second value of check point 1 UINT16 1034 Write/read 

CP1par3 Third value of check point 1 UINT16 1035 Write/read 

CP1par4 Fourth value of check point 1 UINT16 1036 Write/read 

CP1par5 Fifth value of check point 1 UINT16 1037 Write/read 

CP2par1 First value of check point 2 UINT16 1038 Write/read 

CP2par2 Second value of check point 2 UINT16 1039 Write/read 

CP2par3 Third value of check point 2 UINT16 1040 Write/read 

CP2par4 Fourth value of check point 2 UINT16 1041 Write/read 

CP2par5 Fifth value of check point 2 UINT16 1042 Write/read 

CP3par1 First value of check point 3 UINT16 1043 Write/read 

CP3par2 Second value of check point 3 UINT16 1044 Write/read 

CP3par3 Third value of check point 3 UINT16 1045 Write/read 

CP3par4 Fourth value of check point 3 UINT16 1046 Write/read 

CP3par5 Fifth value of check point 3 UINT16 1047 Write/read 

CP4par1 First value of check point 4 UINT16 1048 Write/read 

CP4par2 Second value of check point 4 UINT16 1049 Write/read 

CP4par3 Third value of check point 4 UINT16 1050 Write/read 

CP4par4 Fourth value of check point 4 UINT16 1051 Write/read 



 41 

CP4par5 Fifth value of check point 4 UINT16 1052 Write/read 

CP5par1 First value of check point 5 UINT16 1053 Write/read 

CP5par2 Second value of check point 5 UINT16 1054 Write/read 

CP5par3 Third value of check point 5 UINT16 1055 Write/read 

CP5par4 Fourth value of check point 5 UINT16 1056 Write/read 

CP5par5 Fifth value of check point 5 UINT16 1057 Write/read 

ProbeStop Stop value of external probe UINT16 1068 Write/read 

ProbeMin Value minimum of external probe UINT16 1069 Write/read 

ProbeMax Value maximum of external probe UINT16 1070 Write/read 

     

 

JobPhase Name of current phase STRING 14L 1100 Read only 

JobCode1 Code of current job STRING 24L 1114 Read only 

JobCode2 Code of current job STRING 24L 1128 Read only 

JobCode3 Code of current job STRING 24L 1142 Read only 

JobCode4 Code of current job STRING 24L 1156 Read only 

JobCode5 Code of current job STRING 24L 1170 Read only 

JobCode6 Code of current job STRING 24L 1184 Read only 

JobCode7 Code of current job STRING 24L 1198 Read only 

OrderNumber Order number STRING 24L 1212 Read only 

 

Issue A BIT0: STOP FROM USER INTERFACE 
BIT1: STOP FROM ALLARM CONDITION 
BIT2: TIME OUT 
BIT3: MAX PROBE 
BIT4: MIN PROBE 
BIT5: PROBE NOT OK 
BIT6: HIGH SPEED 

UINT16 2000 Read only 
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BIT7: LOW SPEED 

Issue B BIT0: MAX POSITION 
BIT1: MIN POSITION 
BIT2: MAX CONTACT 
BIT3: MIN CONTACT 
BIT4: MAX CHECK POINT 
BIT5: MIN CHECK POINT 
BIT6: TEST INPUT 2 
BIT7: TEST INPUT 3 

UINT16 2001 Read only 

Issue C BIT4: MAX FORCE 
BIT5: MIN FORCE 
BIT6: MAX BAND 
BIT7: MIN BAND 

UINT16 2002 Read only 

PeakForce Force reached UINT16 2008 Read only 

PeakPosition Position reached UINT16 2014 Read only 

ConctactPos Contact position UINT16 2015 Read only 

ProbeValue Probe measured UINT16 2016 Read only 

CP1ValueA Value A at check point 1 UINT16 2017 Read only 

CP1ValueB Value B at check point 1 UINT16 2018 Read only 

CP2ValueA Value A at check point 2 UINT16 2019 Read only 

CP2ValueB Value B at check point 2 UINT16 2020 Read only 

CP3ValueA Value A at check point 3 UINT16 2021 Read only 

CP3ValueB Value B at check point 3 UINT16 2022 Read only 

CP4ValueA Value A at check point 4 UINT16 2023 Read only 

CP4ValueB Value B at check point 4 UINT16 2024 Read only 

CP5ValueA Value A at check point 5 UINT16 2025 Read only 

CP5ValueB Value B at check point 5 UINT16 2026 Read only 

 

 

* To have the ready signal, the reject piece signal must be reset. To activate the auto 

reset, the option “Disable reset of keypad rejects” must be activated. 
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15.5 Description of Check Point registers 

The check points are described by five different parameters: CPxPar1, CPxPar2, 

CPxPar3, CPxPar4, CPxPar5. The function of these parameters varies according to the 

type of check point. 

With check points, for each piece worked, the instrument measures one or two values. 

These values are available in the CPxValueA and CPxValueB registers. 

The type of check point is indicated by the three least significant bits of parameter 5 

(CPxPar5). 

The types currently available are the following: 

CP_FORCE = 011b 

CP_POSITION = 100b 

CP_PEAK = 001b 

CP_SPEED = 000b 

CP_SETPOINT = 101b 

15.5.1 Registers for check point force 

Register Function Data type 

CPxPar1 Quota di misura forza Position 

CPxPar2 Limite minimo di forza Force 

CPxPar3 Limite massimo di forza Force 

CPxValueA Forza misurata Force 

15.5.2 Registers for check point position 

Register Function Data type 

CPxPar1 Forza di misura quota Force 

CPxPar2 Limite minimo di quota Position 

CPxPar3 Limite massimo di quota Position 

CPxValueA Quota misurata Position 

15.5.3 Registers for check point peak 

Register Function Data type 

CPxPar1 Quota di inizio misura valori minimo 

massimo 

Position 

CPxPar2 Quota di fine misura valori minimo Massimo Position 

CPxValueA Valore minimo misurato Force 

CPxValueB Valore massimo misurato Force 

15.5.4 Registers for check point speed 

Register Function Data type 

CPxPar1 Quota di inizio misura velocità Position 

CPxPar2 Quota di fine misura velocità Position 

CPxValueA Speed Speed 
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15.5.5 Registers for check point setpoint 

Register Function Data type 

CPxPar1 Quota attivazione setpoint 1 Position 

CPxPar2 Quota attivazione setpoint 2 Position 

CPxPar3 Quota attivazione setpoint 3 Position 
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16 Specifications and troubleshooting 

Before calling for assistance, refer to this chapter. 

16.1 Troubleshooting 

Refer to the table below to quickly find the information contained in the manual. 

Problem Cause 

The tool does not allow you to change the 

graph setting. 

It is not possible to modify the origin of the graph and the 

full scale with values that would make the tolerance band 

not visible even only partially. 

The instrument is not communicating with 

the computer. 

See the paragraphs Errore. L'origine riferimento non è 

stata trovata., Errore. L'origine riferimento non è stata 

trovata. 

The acquired curve is not displayed. Check that the origin and full scale of the graph are 

sufficiently correct by comparing them with the measured 

values.  

16.2 The instrument does not communicate via the USB port 

To use the USB port, the instrument drivers must first be installed on the computer. 

16.3 The instrument does not communicate via LAN (ethernet) port 

Check if there is a firewall. If there is a firewall, check that it is not blocking WinScope. 

When the instrument is connected next to the connector, the green LINK light must turn on 

and, if in a fast network, the yellow 100BaseT light. 

Check that the IP address of the instrument is reachable using, for example, the PING 

command. 

 

16.4 Technical data 

The list of the technical features follow: 

Subject Features 

Power supply DC version 24VDC 

1A Absorption (excluding transducer, input and output absorption) 

SAMPLING FREQUENCY 700 samplings/second 

Dimensions 

 

Width: 205 mm 

Height: 175 mm 

Depth: 240 mm 

 

16.5 Characteristics of the instrument 

The Press-Right detects the position-force curve during work. 

Manages and controls the cylinder speed profile. 

Work on a continuous tolerance band by controlling the entire position-force curve. 

Check the height and the peak force values. 
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It controls the stop of the press when reaching a position or a force. 

Check the starting dimension measured on contact with the piece. 

Check critical points of the position-force curve via check-point. 

It manages up to eight consecutive phases with independent parameters. 

All control parameters are stored in 200 independent and selectable jobs. 

Advanced user management with personal passwords and permissions. 

It is possible to connect the Press-Right to the computer and, thanks to the WinScope 

program, to save the curves, modify the settings, perform statistical analysis, print the 

data. 

Saving of curves on internal flash memory accessible via FTP. 

Job selection by barcode reading. 

Registration of the serial number of the piece by reading a barcode. 

Manages up to three antennas for equipment recognition via RFID tags. 

It manages up to three enabling signals. 

It manages up to three additional good / bad control signals. 

Periodic programmable request for tool replacement due to wear. 

Periodic programmable maintenance request. 

Integrated management of a small pick to light system. 

 

 

 

This product must not be disposed of as an unsorted urban waste; secure 

proper recycling. 
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