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1 General information

Press-Right is a control and measurement instrument which, when connected to a press, guarantees the
quality control of the production processes.

Interfaced to a position transducer and a load cell, it continuously detects the position and the instantaneous
force.

1.1 Introduction to control theory

During machining on sample pieces, the data relating to the position of the cylinder and the force exerted by it
are recorded; the graph can be drawn: position-force which is characteristic of the work carried out.

If several machining operations are carried out on similar pieces, the respective position-force curves will also
be similar. If, on the other hand, one of the workpieces differs from the sample, the relative curve will deviate
from the sample curve. It is intuitive how curve control can ensure consistent machining quality.

1.2 Control of the position-force curve

From a theoretical point of view there is an ideal curve which is obtained by machining perfect pieces (in
practice there may be a sample curve obtained by machining carefully selected pieces). Any geometric
tolerances or material differences lead to a deviation from this ideal curve.

In practice, the Press-Right controls the curve through a tolerance range, check points and limits.

The tolerance range positioned around the sample curve is such that if the curve obtained from the current
machining does not pass within this range, the piece is rejected.

The limits control the position and the force values reached. The limits are as follows: minimum peak force,
maximum peak force, minimum peak position and maximum peak position. If the position reached does not
exceed the minimum peak position and/or exceeds the maximum peak position, the piece is rejected. In the
same way, if the force reached does not exceed the minimum peak force and/or exceeds the maximum peak
force, the piece is rejected.

The check points are used to control the curve in discrete points, for example it is possible to check that in a
pre-established position the measured force is between a minimum and a maximum, or that at a pre-
established force the measured position is between a minimum and a maximum. If the values measured in a
check point are not correct, the piece is rejected.

1.3 Absolute and relative odds

The positions referred to the zero of the cylinder are called absolute positions. The positions referred to the
contact position on the piece are called relative positions. The Press-Right can use both absolute and relative
positions. The load cell is used to detect the contact position: when the force measured by the load cell exceeds
a programmed value, the position values is set to zero. This force value is called CONTACT DETECTION
THRESHOLD. The position in which the contact is detected (contact position) is recorded and can be
controlled with two limits, minimum and maximum, to continue or not.



1 Top dead centre
2 Zero absolute position
3 Zero relative position

Figure 1

The accuracy of the contact position detected with the load cell depends on the speed of the cylinder and
above all on the type of piece to be machined. In inserting operations, the two pieces have rounded corners,

consequently the contact position also varies with the variation of the bevel and the force used to position one
part into the other.



2 Installation Press-Right

To install the instrument on the machine, consult the specific manual.



3 How to start

This chapter will walk you through the basics of programming and using the Press-Right instrument.

To better illustrate the operations, it is advisable to carry out the tests in practice; to do this it is very useful to
have an elastic support of adequate compliance to simulate repeated machining.
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To turn on the instrument there is a button on the back. When it is pressed, after a few seconds, the display
lights up and the graph appears.

3.1 Press-Right user interface

If you touch the menu button, the items that make up the main menu are displayed. To select an item in the
menu it is possible to move with the arrow keys and press the OK button or it is possible to directly touch the
item itself.

The RESET button cancels the operations and allows you to return to the main screen.

3.2 First approach

A few seconds after being switched on, the display lights up and shows the main screen. The main screen
displays the graph area and below it the values measured by the connected transducers.
First let's create a simple job:

e Touch the menu button

e Touch the JOBS LIST item

e Touch the CREATE A NEW JOB item

e Enter the name that identifies the job (example TEST 1) and press the enter key.

Note: in the rest of this manual, when it is indicated, for example, “JOBS LIST > CREATE A NEW
JOB” command, we mean to press the menu button, then press the JOB LIST item and finally press the
CREATE A NEW JOB item.



Once the job has been created, indicate to the instrument when it has to stop the press by entering a stop
value. The stop value can be a position value or a force value. The difference in usage is explained in chapter
5. Press EDIT JOB > STOP VALUES > STOP FORCE, enter a value lower than the maximum force that the
press can exert and confirm.

By giving the machine start command, the press will advance and will exert a force that will increase up to the
stop value that we entered previously.

If a too high stopping force value has been entered, the press will continue to push; to stop the press manually,
press the RESET button. In this case the piece is rejected because the work has been interrupted.

3.3 Settheview

The central part of the display is occupied by the position-force graph. It is possible to modify the full-scale
values using the commands in the EDIT JOB > GRAPH SETUP.

3.4 The main menu

Note: Some menu items are not visible if not needed.
The main menu is the first displayed by pressing the menu key.

JOBS LIST allows the choice of the job to be used, the creation of a new job or the elimination of the job in
use.

The PHASE EDIT is visible when the job is divided into several phases. It allows the modification of all the
parameters of the displayed phase.

The EDIT JOB allows you to modify all the parameters of the job in use. When the job is divided into several
phases, the modification of the parameters of the single phase will be possible from the PHASE EDIT menu
while the options common to all phases will be present in the JOB PROPERTIES menu.

The SHOW MEASURED VALUES displays the values measured during the last cycle.

The TOOLS allows the modification of the instrument configuration and the possibility of moving the cylinder
manually.

The item RESET COUNTERS is used to reset the counters of processed pieces. When the batch number is
managed, this menu will be replaced by the NEW PRODUCTION BATCH menu which allows the batch
number to be entered. This number will be stored together with the curve.

The PART NUMBER item allows the insertion of the identification number of the piece being processed. This
identifier will be stored together with the curve.

The USER item allows the operator's identification to be entered. This identifier will be stored together with the
curve.

The PHASE TO EXECUTE item allows you to select the next phase to be executed by modifying the normal
execution sequence. When a phase runs out of sequence, immediate stops on reject are disabled. This
command is available only if the phase sequence is adjusted by the instrument.



4 Jobs management

The Press-Right memorizes all the settings (parameters, tolerance range, limits and counters) relating to the
various jobs in an internal memory. Each group of settings is called Job. Each job has its own name.

JOBS LIST item is present in the main menu. Through this menu it is possible to choose a job among those
present, create a new one, or delete the job in use.

4.1 Create anew job

To create a new job, use the JOBS LIST > CREATE A NEW JOB and give it a name. As a name you can use
the drawing number, the customer's name or whatever you prefer to be able to easily identify it.

When creating a new job, you are asked if you want to make a copy of the job currently in use. If you choose
to copy the current job, the parameters of the current job will be duplicated and will remain unchanged. In the
other case the new one will be empty.

After having created the job, you can set the parameters, options and tolerance range.

4.2 Change the job name

To change the name of a job, you must first select it. Once you have selected the job to which you want to
change the name, you can use the command EDIT JOB > PROPERTIES AND OPTIONS > NAME OF THE
JOB.

4.3 Selecting ajob

SELECT JOB command is present in the JOBS LIST menu. When this command is selected, the list of jobs
present is displayed. The date and time the job was last modified is shown next to the name.

If the list is very long, look for the name by touching the magnifying glass icon.

To prevent manual selection of a job, the selection of jobs can be locked with a password. To activate the
password, activate the Job selection option in the TOOLS > PASSWORD > FUNCTIONS WITH PASSWORD.

4.4 Selection of ajob by barcode

If a barcode scanner is connected, it is possible to select the job automatically by simply reading the barcode.
To activate this function, activate the Jobs with identification codes option in the TOOLS > SETUP > JOB
SELECTION.

After activating the Jobs with identification codes option, the relative identification codes must be assigned to
the jobs. To assign the codes to the job see chapter 4.8.

4.5 Job selection by inputs

With selection by inputs, the instrument changes the job when the state of the digital inputs changes.
The job number is derived from the binary combination of the inputs.
To activate job selection, you must define the inputs you want to use for selection as JOB SELECTOR inputs.

You must also activate the option Selectable jobs with numerical index found in the TOOLS > SETUP >
OPERATION SELECTION menu. After activating the option, you have to assign the jobs their identification
number via the EDIT JOB > PROPERTIES AND OPTIONS > CODES OF THE JOB menu.
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4.6 Selecting a job via tool recognition

It is possible to connect sensors and RFID antenna to the instrument to automatically recognize the tool used.
It is possible to recognize up to three parts, for example the punch, the placement, and a simple mechanical
selector. These signals can be used to automatically select the job to be used or to enable machine operation.

To activate the recognition of the tools, the relative options must be configured in the TOOLS > SETUP >
ELECTRICAL CONNECTIONS > TOOLS.

After having configured the recognition of the tools, it is necessary to activate the automatic selectionin TOOLS
> SETUP > JOB SELECTION. Finally, the relative tool code must be assigned to the jobs in EDIT JOB >
PROPERTIES AND OPTIONS > ACCESSORIES.

4.7 Selection of ajob via fieldbus

It is possible to select the job to be used via the fieldbus in three different ways: via the job name, via the
identification code or via an index number.

4.7.1 Selection from fieldbus by name
To select a job, first write the code of the desired job in the string buffer at the address 45, then write command
3in the CONTROL_WORD_OUTPLC.

4.7.2 Selection from fieldbus via the identification code
To activate this function, activate the Jobs with identification codes option in the TOOLS > SETUP > JOB
SELECTION.

After activating the Jobs with identification codes option, the relative identification codes must be assigned to
the jobs. To assign the codes to the job see chapter 4.8.

To select a job, first write the code of the desired job in the string buffer at the address 45, then write command
2 in the CONTROL_WORD_OUTPLC.

4.7.3 Selection from fieldbus by index number
To activate this function, activate the Jobs selectable by index option in the TOOLS > SETUP > JOB
SELECTION.

After activating the Jobs selectable by index option, the relative index number must be assigned to the jobs
in EDIT JOB > PROPERTIES AND OPTIONS menu.

To select a job, write the index number of the desired job in register 90.

4.8 Modify job identification codes

To assign the codes to the job, first select the job and then go to the EDIT JOB > PROPERTIES AND
OPTIONS menu. Depending on the configuration, it will be possible to enter the identification codes and the
identification number of the equipment. Up to seven codes can be assigned to each individual job.

Notes:

When the code entry window is displayed, you can use the barcode reader to automatically enter the job
identification code.

If an @ is inserted in the code, this character will be ignored in comparison with the read code.

49 Copyajob

To copy a job, it is first necessary to select the job to be copied; once the job to be copied has been selected,
the new job must be created using the JOBS LIST > CREATE A NEW JOB command and, when asked to
copy the job, answer YES.

11



4.10 Delete ajob

To definitively eliminate a job from the instrument's memory, select the JOBS LIST > DELETE JOB command.

4.11 Editajob

The EDIT JOB menu allows the modification of all the parameters that make up the job. If the job has several
phases, in this menu it will be possible to modify the parameters common to all the phases while the
modification of the parameters of each single phase will be possible from the MODIFY PHASE menu.

Note: In general, in jobs, the parameters set equal to zero will be ignored by the instrument.

4.12 Job counters

Each job has a piece counter. To access the counter options, select the menu EDIT JOB > SCHEDULING.

In this menu it is possible to reset the piece counter or choose a maximum number of pieces to block the
instrument.

4.13 The graph

The submenu GRAPH SETUP allows you to modify the values of the graph axes to enlarge and show the
interesting part of the position-force curve.
Auto range
This function adapts the scale of the graph to display the curve of the last machining performed.
Graph origin
It is the origin value of the horizontal axis of the dimensions, this parameter allows you to hide all the run
of no interest, such as the approach run. If relative dimensions are used, the origin should normally be
set equal to zero.
End scale position
The full scale of the positions indicates the maximum stroke which is displayed in the graph.
End scale force
The full scale of the forces indicates the maximum force that is displayed in the graph.

4.13.1 How to set up the graph
After executing a piece, it is possible to view the measured values. From these it is possible to obtain the
values of the graph axes.

As the origin of the graph, enter a value slightly lower than the measured starting height. As end scale of the
positions, enter a value higher than the measured position reached.

As end scale of the forces, choose the value higher than the measured reached force.
For convenience, the values measured in the last pressing are shown in the value entry box.

4.14 Phase management

It is possible to manage multiple processing phases for a single job. The phases can be considered as "under
construction" which contribute to the completion of a more complex process (for example the insertion of a
bearing and a gear on the same shatft).

The phase management functions are normally hidden. To make them visible, select the Job phase
management option in the TOOLS > SETUP > VISIBLE OPTIONS menu.

To use more phases, it is necessary to enable the execution of phases in the menu EDIT JOB > ENABLE
PHASES. Once you have enabled the phases, you can change their name.

12



When a job has several phases, the main menu will contain the PHASE EDIT item where it is possible to set
all the parameters of the displayed phase and the JOB PROPERTIES item where it is possible to set the
options common to all phases. In this manual we will continue to indicate the location of many commands in
the EDIT JOB menu but if we are using phases, the same commands will be in the PHASE EDIT menu.

The list of phases is always visible in the upper part of the graph, with the keys 00 it is possible to change
the phase displayed and modify its parameters with the PHASE EDIT menu. The phase that will be performed
is always indicated at the bottom right of the main page. Changing the phase displayed with the arrow keys
does not change the phase that will be performed. To change the phase to be executed it is possible to touch
the phase name at the bottom right or use the PHASE TO EXECUTE command.

The phases will be performed automatically in sequence. If you want to carry out a phase individually out of
sequence, select the Do not perform the phases in sequence option in the TOOLS > SETUP > JOBS
SELECTION menu. In this case it is not possible to change the phase that will be performed from the menu.
It is also possible to have a single phase repeat several times by activating the Phase repeat options in the
TOOLS > SETUP > VISIBLE OPTIONS menu.

4.14.1 Phase copy

To copy a phase, you can use the COPY PHASE and PASTE PHASE commands in the PHASE EDIT menu.
The copy phase command stores the current job number and the current phase number. The paste phase
command overwrites the current phase with the job phase stored with the copy phase command.

13



5 Parameters

After creating a new job, the first thing to do is to set the job options in the EDIT JOB > PROPERTY AND
OPTIONS menu.

Once this is done, it is possible to set the operating parameters.
Note: In the jobs the parameters set equal to zero will be ignored by the instrument.

5.1 Stop values

The first thing to do is tell the instrument when to stop the press. To set the stop values, use the EDIT JOB >
STOP VALUES menu.

The Press-Right can stop the press when the force reaches a certain value (Stop force) or when the press
reaches a certain height (Stop position).
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9000
Stop force
8000
7000
6000
5000

4000

Stop position

3000

2000

1000

0

0.00 50.00 100.00 150.00  200.00

Note: The press is also stopped when the maximum acquisition time expires.

5.1.1 Notes on stop values
When both the stopping force and the stopping position are set, it is sufficient to exceed one of the two to
command the stop.

It is normal to detect values reached higher than the stop values; this is due to the intervention delay of the
electromechanical parts.

It is possible to continue pressing when the stop values are reached for a pre-set time. To set the press stop
delay time, use the STOP VALUES > STOP DELAY.

5.1.2 How to choose the stop values

The stop must be set differently depending on the type of machining. Three types of processing can be
distinguished:

1) Full shrinking, chamfering or work up to a mechanical stop.

2) Work up to a position (without mechanical stops).

3) Bending and breaking test.

14



5.1.2.1 Stop with mechanical stop.

In most cases the press is used to carry out an insertion up to a mechanical stop. In this case the curve will be
similar to that in next figure, i.e. the force will be zero for the entire approach stroke, once the piece has been
reached (at the contact position) the force will begin to increase until the mechanical stop is reached where it
will increase up to the maximum force value of the press (vertical part of the curve).
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DU.OU 50.00 100.00 150.00 200.00
Stop force must be used as the force will always reach the maximum that the press can exert. If we used the
stop position this could not be reached if the piece is slightly higher than expected or it could be reached even
before completing the job if the piece is too low.
The stop force must be chosen such as to guarantee the completion of the machining.
The stop force must be less than the breaking force of the workpiece or the tool.
The stop force must be less than the maximum force the press can exert.

5.1.2.2 Stop without mechanical stop

It is possible to stop the descent of the press rod at an established position by setting the stop position. In
this case the instrument will switch the valve which controls the descent of the press as soon as the stop
position is reached. This valve will take some time to switch and more time will be necessary before it begins
to evacuate the pressurized air in the cylinder: for these reasons, the real stop of the press will be at a higher
level than the set stop value. This error will be greater the higher the descent speed and the greater the
difference between the force required to do the work and the force of the cylinder.

5.1.2.3 Stopping during a bending and breaking test

The force that the piece under test must resist is used as the stop force. In the event of breakage, the stopping
force will not be reached, therefore it is also necessary to set the stop position value equal to a value that
cannot be reached without breaking the piece.

If the piece resists the stopping force, once the test is over, the reached position will be equal to the bending
that the piece has had. It will then be possible to verify whether the deflection obtained is the one expected
using the position limits.

If the piece breaks before the impact force is reached (next figure), at the end of the test, the reached force
will be equal to the breaking force of the piece.

To verify that the piece has not broken and has withstood the force required, it is necessary to enter the
minimum force limit equal to the stop force value.

15
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5.2 Control limits

The control limits, together with the range, determine the outcome of the job.

It is possible to set the limits of the reached force, the limits of the reached position, the limits of the contact

position and the check points.

Note: Control limits, set equal to zero, are not used.

Contact position limits
They control the contact dimension of the working. For a part to be classified as good, the measured
contact dimension must be above the minimum contact dimension limit and below the maximum contact
dimension limit.

Peak Position limits
They control the maximum position reached during machining. For a piece to be classified as good, the
measured position reached must be higher than the minimum position reached limit and lower than the
maximum position reached limit. If the minimum reached position limit is not set and the tolerance band
is present, the position of the band is used as the minimum limit.

Peak Force limits
They control the force reached during machining. For a piece to be classified as good, the maximum force
achieved must be above the minimum force limit and below the maximum force limit.

Contact detection threshold
The initiation force is the force threshold used to measure the contact height.

5.2.1 How to choose the limits

Contact dimension limits let you control the dimensions of components even before the job begins. They can
be used to check the dimensions of the pieces to be assembled or to check that there are all the details
necessary for the machining.

The choice of the limits of the position values and of the force reached depend on the type of machining. In
general, you can follow this guide:

16



Limits with machining with mechanical stop

When there is a mechanical stop, the press will always reach either the stop force. The maximum peak force
limit can be used to ensure that the maximum force that the workpiece can withstand is never exceeded.

In this type of work, to control the effective force required, the tolerance range or the checkpoints are
necessarily used.

The peak position limits are used to verify that the dimensions of the assembly, once machining is completed,
are within tolerance.

Limits with machining without mechanical stop
The peak force limits can be used to control the maximum force that has been applied to the workpiece.

The peak position limits are used to verify that the dimensions of the assembly, once machining is completed,
are within tolerance.

Limits for bending and breaking tests

In bending tests, the force limits are used simply to verify the force that has been applied while the position
limits are used to verify the measured deflection.

In breaking tests, force limits are used to verify the force that was required to break the piece.

5.3 Checkpoints

Checkpoints are additional tools for curve control. Up to five checkpoints can be defined. Each checkpoint can
be used to:

Check force

Measure and control the force at a pre-set position. This check point is also useful for having a discrete
value at the end of pressing to be displayed or sent via fieldbus.

Check position

Measure and control the position at a pre-set force. This check point is useful for checking deformation at
a pre-set load. It is also useful to have a discrete value at the end of pressing to be displayed or sent via
fieldbus.

Digital force filter
This check point is useful to clean the curve from unwanted vibrations.
Minimum maximum measurement

This check point is useful for having the minimum and maximum force value in a section of the stroke to
be displayed or sent via fieldbus.

Slope control

This check point measures the force at the check position and at a certain distance verifies that the force
variation is between a minimum and a maximum.

Localized stop

This check point commands the cylinder to stop when a pre-set force is reached. The force control takes
place only in a pre-established section of the stroke. The stop can take place as soon as the force is
exceeded or after a pre-set stroke.
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6 Job options

The following job options can be modified with the EDIT JOB > PROPERTIES AND OPTIONS > OPTIONS.
If the job is divided into several phases, the options relating to a single phase are found in the PHASE EDIT >
PROPERTIES AND OPTIONS menu, while the options relating to the whole job are found in JOB
PROPERTIES.
Use relative positions
By activating this option, the relative positions are used instead of the absolute ones (chapter 0).
Request batch ID
By activating this option, before running a batch, you are asked to enter a batch identifier. To use this
option, you need to activate the Lot id management option in the TOOLS > SETUP > VISIBLE OPTIONS
menu.
Ask for the piece code
By activating this option, before executing each piece, you are asked to enter a numerical code that
identifies the piece itself. The piece code can also be set via a barcode scanner. To use this option, it is
necessary to activate the Part number management option in TOOLS > SETUP > VISIBLE OPTIONS
menu. Contact Alfamatic to find out which barcode readers are compatible with the instrument.
Save curves of pieces good
Save the curves of the good pieces on the internal flash memory.
Save curves of pieces rejected
Saves the curves of the rejected pieces on the internal flash memory.
Do not use rejected basket
Disables basket control for rejected pieces.
Request a confirmation with rejected
By activating this option, when a phase is recognized as reject, a message is shown which allows you to
confirm the reject, repeat the reject phase or move on to the next phase. To use this option, you need to
activate the Request a confirmation with rejected phase option in the TOOLS > SETUP > VISIBLE
OPTIONS menu.
Ask for the operator code
By activating this option, you are asked to enter the operator ID. This identifier will be stored together with
the curve. To use this option, you need to activate the Operator ID management option in the TOOLS >
SETUP > VISIBLE OPTIONS menu.

6.1 Counters

Through the EDIT JOB > SCHEDULING command it is possible to configure the counters and the data saving
and maintenance options.

There is a counter for good pieces and two counters for normal and special pieces. There is also a counter
that counts the number of cycles performed with a single tool. Finally, it is possible to enable the saving of the
curves in the internal memory of the instrument. To transfer the curves, it is necessary to connect the
instrument via the LAN port and use the Alfamatic AutoCopy program.

Reset the number of good pieces

Resets the counter of the number of good pieces made.

Reset the number of rejected pieces

Resets the counter of the number of rejected pieces.

Save curves

Activates the saving of the curves in the internal memory of the instrument.

Save a good curve every
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If you only want to save some curves, with this parameter you can set every how many pieces you want the
curve to be saved.

Number of good pieces to be produced

Number of pieces to produce. When the good parts counter reaches this value, a warning appears on the
instrument screen.

Maximum number of rejected pieces

Maximum number of rejected pieces, once this number is exceeded, a warning appears on the instrument
screen.

Tool life

Number of pieces that can be made with the same tool, once this number is exceeded, a warning appears on
the tool screen.

If a tool is shared among several jobs, it is possible to activate the Shared tools table option in TOOLS >
SETUP > ELECTRICAL CONNECTION > TOOLS > "THIRD TOOL". With this option active, a table of twelve
tools is created which can be shared between several jobs. The table is visible in the TOOLS >
MAINTENANCE menu. To indicate in the job which tool in the table must be used, access the EDIT JOB >
PROPERTIES AND OPTIONS > ACCESSORIES menu.
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7 The tolerance range

The tolerance rage is used to control the curve and consequently to control the quality of the piece.
The tolerance rage consists of two lines called the upper border and the lower border.

For the piece to be classified as good the points representing the curve cannot be above the upper edge, and
cannot be below the lower edge.

The figure shows a curve relative to a good piece, as it is included between the two edges of the tolerance
range.
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Each border is composed of a sequence of points joined by segments.

7.1 Create the tolerance range

To create a new tolerance range, use the EDIT JOB > TOLERANCE RANGE menu. If the tolerance range
does not exist, confirmation is requested for the creation of a new one. Choosing YES, a simple tolerance
range formed by two points for each edge appears in the graph.

7.2 Modify the tolerance range

To modify the tolerance range use the EDIT JOB > TOLERANCE RANGE menu. When moving the points,
be careful not to switch the top edge with the bottom edge.

The modification of the tolerance range must be performed by moving the points that determine the two edges.
When the tolerance range is modified, only one point of one of the two edges is highlighted, this point is the

active one, i.e. it is the one that can be moved using the keys ceeo It is possible to change the
active point with the "select previous point" and "select next point" commands. To activate the points of the
other border, press the command "select other edge". The force and position of the active point are displayed
below the graph.

You can add a point by dividing the segment following the active point in two parts. To do this, press the "add
new point" command.

It is possible to delete the active point with the “delete point” command.
When using the arrow keys, it is possible to change the speed by pressing the "change size of step" command.
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7.3 Remove the tolerance range

To eliminate the tolerance range use the EDIT JOB > TOLERANCE RANGE > DELETE menu.
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8 Rejected pieces

When a rejected piece is detected, the instrument stops preventing the execution of new pieces. In the
standard configuration, to re-enable the instrument it is necessary to press the RESET key.

Furthermore, if the reject basket is present, the piece must pass through the sensor; the RESET key allows
you to open the safety door if present.

If the job has multiple phases, the Press-Right can request confirmation for the rejected.

If the tolerance band is not reached by the curve and if the minimum quota limit is not present, the piece is
signaled as reject due to the minimum quota not being reached.

8.1 The causes of rejected

A piece can be good or rejected. The reject can be caused by one or more different causes. The following list
shows all possible reject causes.
Maximum force exceeded
The peak force has exceeded the peak maximum force limit. Note: the peak force may not coincide with
the force of the last point of the curve.
Minimum force not reached
The peak force has not reached the peak minimum force limit. Note: the peak force may not coincide with
the force of the last point of the curve.
Below lower edge (low force)
The curve has passed under the lower edge of the tolerance range.
Above upper edge (high force)
The curve has passed over the upper edge of the tolerance range.
Aborted by the keyboard
The execution of the job was interrupted by the operator who pressed the RESET key.
Execution interrupted
The start command was removed during the execution of the job. It is usually caused by the intervention
of emergencies or for release of start buttons.
Time expired
The execution of the job took too long. You can increase the maximum time by reducing the acquisition
frequency using the Press-Right Setup program.
Additional test value high
The value of the supplementary transducer is higher than the maximum supplementary limit.
Additional test value low
The value of the supplementary transducer is lower than the minimum supplementary limit.
Additional test wrong
The extra check caused the discard.
High speed
Your speed is above the maximum speed limit.
Low speed
The speed is below the minimum speed limit.
Maximum position exceeded
The peak position has exceeded the maximum peak position limit. Note: the peak position may not
coincide with the position of the last point of the curve.
Minimum position not reached
The peak position has not reached the minimum peak position limit or has not reached the tolerance
range. Note: the peak position may not coincide with the position of the last point of the curve.
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Maximum contact position exceeded

The contact position measured is higher than the maximum contact position limit.
Contact before minimum limit

The contact position measured is lower than the minimum contact position limit.
Check point high

The value measured at the checkpoint is higher than the maximum value.
Check point low

The measured value at the checkpoint is below the minimum value.

8.2 Rejected management

For each cause of reject it is possible to indicate to the instrument how to classify the piece and how to behave.
For the configuration, choose the desired reject cause in the list that appears with the EDIT JOB >
PROPERTIES AND OPTIONS > REJECTED MANAGEMEN. Once the reason for the rejection has been
selected, the following options can be configured:
PROCEDURE WITH REJECTED
For each cause of reject it is possible to immediately stop the press as soon as the cause of reject is
detected, block the press in operation and request the insertion of the unlock password.
CLASS: NORMAL / SPECIAL
For each cause of reject it can be classified as normal or special. This allows you to classify the rejected
to separate them. For example, it is possible to separate recoverable rejected from unrecoverable
rejected. When there is a special reject the Press-Right activates the second reject signal and counts the
piece separately. In this way it is possible to know, for example, how many pieces are rejects due to
operator error.

The first item in the list of reject causes is ALL, by selecting this item, the choices that will be made will be
applied to all the causes in the list.

8.3 Additional sensors

Allows configuration of additional control signals when they are present.

8.4 Force transducers

Allows the choice of force transducers to be used when there are multiple force transducers.

8.5 Accessories

In this menu it is possible to:

Exclude the check of the enable signals if present.

Choose which equipment to use to carry out the work.

Which component must be requested before carrying out the work when a pick-to-light system is connected.

8.6 Repetition

With this command it is possible to enter the number of repetitions of the single operation.

8.7 Verification

With this command it is possible to configure the self-verification of the job.
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8.8 Codes of the job

In this menu it is possible to indicate the job name, the selection index and which part of the barcode identifies
the job code.
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O Measured values

The Press-Right stores the displacement-force curve and measures some quantities that can be controlled
thanks to the limits. The last curve can be analyzed with the analysis cursor. The quantities measured can be
displayed at the end of each process.

9.1 The measured value page

In the main menu is present the SHOW MEASURED VALUES command. This command shows the measured
values of the last process carried out. This page can be displayed at the end of each cycle by changing the
option in the menu TOOLS > DISPLAY OPTIONS. To close the page just touch the screen.

9.2 Analysis cursor

It is possible to know the force in a given position using the cursor. The cursor appears as a vertical line in the
graph. When the cursor is displayed, the force of the curve at the position indicated by the cursor and its
current position are shown below the graph.

To display the cursor, touch the horizontal ruler of the graph.

The cursor can be moved to the right or left with the keys Ge
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10 The tools menu

The Press-Right configuration is performed via the TOOLS menu. The detailed description of the single
configuration options can be found in the following chapters.
This menu contains the following submenus:
DISPLAY OPTIONS
Allows you to setup the main page.
MAINTENANCE
Allows the setting of a scheduled check of the machine.
DIAGNOSIS
In this submenu it is possible to calibrate the transducers and check the operation of the inputs and
outputs.
Note: To view the real-time status of the inputs and outputs, it is possible to activate the Display the
status of the command signals option in the TOOLS > DISPLAY OPTIONS menu.
PASSWORD
It allows the configuration of users and passwords and allows the selection of the instrument functions
that must be locked with the password.
SETUP
It allows the hardware configuration of the instrument.
LANGUAGE
Allows you to change the instrument language.

10.1 Display options

The display options modify the behavior of the main page.

Do not show measured values
At the end of the acquisition, normally, a page is shown which contains the measured values and the
outcome of the processing. By activating this option, the window will not appear automatically, but you
will have to manually select the SHOW MEASURED VALUES command in the main menu.

Do not remove old curves
By activating this option, all curves will be superimposed on each other creating a strip representing the
dispersion of forces. This option doesn't work with phases.

Displays the status of the command signals
By activating this option, the status of the inputs and outputs is displayed above the graph.
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11 Instrument configuration

In general, when the Press-Right is supplied already connected to the machine, it is not necessary to configure
it.
Thanks to the many configuration options, the Press-Right can adapt to your needs.
To configure the Press-Right, access the TOOLS > SETUP menu.
This menu contains the following items:
GENERAL OPTIONS
It allows you to configure the Press-Right based on the type of press connected and to activate some
functions.
ELECTRICAL CONNECTIONS
It allows to set the function of each input and each output, to configure the connected transducers and to
configure the recognition of the tools.
CYLINDER SETUP
Allows configuration of the cylinder. Some parameters are protected by a particular password which must
be requested from Alfamatic.
JOBS SELECTION
Configure the selection of jobs and phases. See chapter 4.
NETWORK AND CLOCK
Allows definition of the machine name, network settings and system clock.
VISIBLE OPTIONS
Allows you to indicate which options should be visible.

11.1 General options

Some general options depend on the type of press to which the instrument is connected, other options activate

particular functions.

Disable button for reset rejected
If there is an input configured as RESET, by activating this option it will no longer be possible to reset the
instrument after a rejected piece without activating the relative reset input.
If there is NOT an input configured as RESET, by activating this option it will no longer be necessary to
reset the instrument after a scrap piece.

Allow stop by external command
Normally it is the Press-Right that stops the acquisition and stops the press. If the START signal is
removed during acquisition, the Press-Right stops the press and reject the piece due to unexpected
interruption. By activating this option when the START input is deactivated, the Press-Right ends the
acquisition and checks the curve.

Wait for supervisor system connection
By activating this option, the Press-Right is blocked and enabled by the supervision system connected
via fieldbus.

Wait for computer connection
By activating this option, the Press-Right does not allow the machining of the pieces if it is not connected
to the WinScope program.

Press with manual approach
This option must be activated if the press controlled by the Press-Right has the piece approach lever and
the automatic working stroke, for example the presses M-OP model.
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Mechanical press
This option must be activated if the press controlled by the Press-Right is completely mechanical. For

example, toggle presses, rack and pinion presses...

11.2 Job selection

These options modify the method used by the instrument to automatically select jobs and phases. The options
are accessible from the TOOLS > SETUP menu. More information regarding automatic selection is in chapter
4.3.
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12 Diagnosis

The diagnostic function allows: displaying the status of the inputs, displaying and forcing the outputs,
calibrating the transducers.

Given the complexity of these latter operations, their use is recommended only to qualified personnel.
Activated inputs and outputs are highlighted with a black rectangle.

To force the outputs, move the cursor with the keysc o desired output and press the OK key. You must
know the hardware password in order to force an output.

The firmware version of the instrument is also displayed in the diagnostic window.

Note: In diagnosis the instrument does not work. To check the status of the inputs and outputs while the
instrument is running, press the point key in the main display (outside the menus).

12.1 Firmware version

The Press-Right has several microprocessors inside. To find out the version of the software contained in the
microprocessors, it is possible to view the diagnosis window TOOLS > DIAGNOSIS.
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13 Special configurations

The Press-Right tool is very versatile. Thanks to Alfamatic's years of experience in pressing, the instrument is
set up to solve the most varied customer needs. In order not to unnecessarily complicate the use of the
instrument, these functions are hidden and must be made visible manually in the instrument configuration.

This chapter describes some of the possible functions. If you have a particular need, contact Alfamatic to find
out if your need is already foreseen.

13.1 Additional force transducer

Up to six force transducers can be connected to the Press-Right to monitor as many force-position curves.
While each force transducer detects the force of one channel, there is only one position transducer in common
for all channels.

On the right of the graph, the color of the curve of each channel is visible. The force of only one channel at a
time is displayed below the graph. To change the channel of the displayed force just touch the channel list on
the right.

In order to connect an additional force transducer, the Press-Right must have inputs for each load cells.

13.1.1 Additional force transducer configuration
To enable the additional transducers, use the TOOLS > SETUP > ELECTRICAL CONNECTIONS >
TRANSDUCERS menu.

13.1.2 Use of additional force transducer
It is possible to exclude one or more channels from monitoring using the submenu EDIT JOB > PROPERTIES
AND OPTIONS > SELECT CHANNELS.

13.2 Self-test

The self-test function is used to periodically check the functioning of the machine by executing specially
prepared sample pieces.

To use this function, it is necessary to make the relative options visible from the TOOLS > SETUP > VISIBLE
OPTIONS > SELF-TEST menu.

The execution of the sample pieces can be performed: every time the instrument is switched on, every time
the job is changed, every time the job is modified, every number of pieces.

Depending on your needs, it is possible to create deliberately rejected sample pieces or calibrated pieces
which must be marked as good.

For self-testing, you can also use a specially created special job. The name of this job must be exactly the
same as the name set in the self-test setup menu.

The self-test configuration is possible from the TOOLS > SETUP > SELF-TEST menu.

To reserve the self-test procedure to qualified personnel, this function can be blocked with a password by
activating the relative option from the TOOLS > SETUP > PADSSWORD > FUNCTIONS WITH PASSWORD
menu.

For each single job it is possible to exclude the self-test function.

13.2.1 Self-test operation
A message appears on the screen when the self-test procedure must be performed. Tapping the message
initiates the self-test.
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During the self-test, the self-test bar appears at the top of the main page. The self-test bar indicates how many
test cycles remain to be performed and, if additional test inputs are in use, the status of the test signals. To
cancel the self-test, tap the X in the top left of the self-test bar.

13.3 Management of supplementary controls

In addition to curve control, up to three additional sensors can be connected to determine if the part is good or
rejected. In practice, the outcome of the machining can be conditioned by the logic status of three inputs. This
logical state can be checked at various times during the working.

For additional control number 1, the Press-Right can also activate an output before carrying out the control
and, after a pre-set time, read the state of the input.

To use the additional controls, first of all, assign the TEST function to the input to which the sensor is
connected.

The TOOLS > SETUP > ELECTRICAL CONNECTIONS menu allows you to configure the inputs and assign
a descriptive name in SIGNAL OPTIONS submenu.

In the EDIT JOB > PROPERTY AND OPTIONS > ADDITIONAL SENSORS menu it is possible to establish
when and how to carry out the additional checks.

13.3.1 Additional control options
The additional control options are as follows:

No supplementary control
The additional check is not performed.

Check at the start
The supplementary check is performed when the instrument receives the START command.

Check at the stop
The additional check is carried out when the tool wants to command the stop and the piece is good.

During pressing
Additional control is performed during pressing.

Use as enable
The signal is checked at the start of work to enable or disable the cycle.

13.4 Tools recognition

The Press-Right can be programmed to recognize the equipment (tools) mounted on the press.

Thanks to the recognition of the tools, it is possible to prevent the operation of the press if the equipment is
not the one foreseen by the job, or it is possible to have the correct job selected according to the mounted
equipment or again it is possible to have the work phase automatically selected according to of the tool in use.

For equipment recognition, up to three RFID transceivers can be connected to the instrument or the binary
combination of some inputs can be used.

To use the RFID antennas, you must have the Press-Right with the specific input.

13.4.1 Recognition configuration
To set how the tools are identified, access the TOOLS > SETUP > ELECTRICAL CONNECTIONS > TOOLS
menu.
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13.4.2 RFID tablet writing
To write the identification number of the tool, access the TOOLS > SETUP > ELECTRICAL CONNECTIONS

> TOOLS menu.

13.4.3 Select tool to use
To indicate the tool that must be used for the operation, access the EDIT JOB > ROPERTIES AND OPTIONS

> TOOLS menu.

13.4.4 Automatic selection of work with tool
To automatically select the job according to the tool mounted on the press, activate the relative option in the
TOOLS > SETUP > JOB SELECTION menu.
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14 Data storage

The Press-Right is able to memorize the production data in the internal memory. In practice, for each piece
produced, a file is created which contains the following information:

e The recorded force-displacement curve.

e The job settings used when recording the curve.

e The serial number of the part.

e The order number.

e The operator ID.

e The date and time.
The file created is stored in a flash memory inside the Press-Right instrument. The AutoCopy software for
Windows is available which autonomously moves the curves from the instrument's memory to a folder on the
computer. The WinScope software for Windows allows the visualization of the curves contained in the moved
files.

The instrument can be configured so that the serial number is requested for each piece.
Through the instrument menus it is possible to enter the job number and the operator ID.

For quick entry of the various identifiers, it is possible to use a barcode scanner connected to the USB 2 port
of the instrument. Contact Alfamatic to find out which barcode readers are compatible with the instrument.

Note: There are limitations on the length of these fields as indicated in the technical characteristics.
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15 Password

The Press-Right can store a list of users with their identification codes.

The identification code is a four digit number.

The last three digits are never displayed and act as the password.

Permissions can be defined for each user, i.e. which functions they can access.

There is an administrator password that allows access to all functions and user management.

To add, modify or delete a user it is necessary to know the password of a user who can manage the user list.

USER LIST
In the user list you can add or edit a user. When adding a user, it is necessary to indicate the descriptive
name, the password (four digits) and the permissions that the new user will have. The first digit of the
password must be different for each user.

ADMIN PASSWORD
The admin user cannot be deleted and has full permissions. To change the password, you need to know
the old password or, if it has been lost, you need to contact Alfamatic to send him the code that appears
in the old password entry window. The default administrator password is 9724.

LOGOUT
When a user's password is entered, an icon is displayed on the main page indicating the name of the
user who has accessed. This avoids the constant entry of passwords. To cancel access, you can use the
TOOLS > PASSWORD > LOGOUT command or press the RESET key.

REMOVE USER
Allows you to delete a user.

FUNCTIONS WITH PASSWORDS
This menu defines which instrument functions are accessible only by entering the password. The user
who enters his password will be able to access only if he has the relative permissions enabled.
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16 Calibration

The calibration operation must be performed by trained and qualified personnel.

To calibrate the transducers connected to the Press-Right you need to access the TOOLS > DIAGNOSIS
menu.

For each transducer, the raw output value from the converter and the real value of the measured quantity are
shown. The transformation from the converter value to the actual value is achieved via the gain:

Actual value = drive value x gain.

To calibrate a transducer, you must first modify the offset to bring the raw value to zero and then calculate the
gain to obtain the real value.

Calibration requires the password of a user with maintenance permissions.

16.1 Force transducer calibration

The offset is the value that is subtracted from the output value of the analog-digital converter.

The gain is the multiplication factor that adjusts the displayed value. If the gain is greater than 3, it is better to
change the unit of measure and the number of decimal digits.

Force transducer gain is best calculated using a calibrated reference load cell, alternatively a theoretical gain
can be entered.

The following table shows the recommended configuration and theoretical gain value.

Full scale load cell

100 N (10 kg) Gain=0.3 N 1 decimals daN 2 decimals

250 N (25 kg) Gain = 0.75 N 1 decimals daN 2 decimals

500 N (50 kg) Gain=15 N 1 decimals daN 2 decimals

1 kN (100 kg) Gain=3 N 1 decimals daN 2 decimals

1 kN (100 kg) Gain=0.3 daN 1 decimals kN 3 decimals
2.5 kN (250 kg) Gain =0.75 daN 1 decimals kN 3 decimals
5 kN (500 kg) Gain=15 daN 1 decimals kN 3 decimals
10 kN (1 1) Gain=3 daN 1 decimals kN 3 decimals
10 kN (1 1) Gain=0.3 daN 0 decimals kN 2 decimals
25 kN (2.5 1) Gain =0.75 daN 0 decimals kN 2 decimals
50 kN (5 1) Gain=15 daN 0 decimals kN 2 decimals
100 kN (10t) Gain=3 daN 0 decimals kN 2 decimals
100 kN (101) Gain=0.3 kN 1 decimals
250 kN (25 1) Gain =0.75 kN 1 decimals
500 kN (50 1) Gain=15 kN 1 decimals
1000 kN (100 t) Gain=3 kN 1 decimals

16.2 Position transducer calibration

The position transducer can be an incremental encoder or an analog transducer.

The incremental encoder is preferred as the accuracy does not depend on the maximum stroke and is not
affected by electrical noise.
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16.2.1 Encoders

The encoder is connected to a x4 counter which improves the physical resolution of the transducer by four
times.

The offset is the value that is subtracted from the output value of the analog-digital converter.

The gain is the multiplication factor that adjusts the displayed value.

It is important to understand that the position is reset to a position that is not TDC. The zero position is
determined by the encoder index signal. The index must be positioned slightly further than the cylinder
rearward position. The position value indicated by the instrument, after the first movement of the cylinder, must
therefore be negative.

16.2.2 Analog input

The Press-Right has an analog input with a 12-bit analog-to-digital converter.

The offset is the value that is subtracted from the output value of the analog-digital converter.

The gain is the multiplication factor that adjusts the displayed value.

The theoretical value of the gain to obtain hundredths of a millimeter is obtained from the following formula:
Gain = (Nominal stroke in millimeters) / 40.96

16.3 Encoder alignment

The encoder reset position is determined by the concurrence of the TDC signal (cylinder backwards) and by
the presence of the encoder index signal.

When the instrument is switched on, the value displayed is zero whatever the position of the cylinder: the
values are restored only on the first passage through the index position. Therefore, a negative quote must be
indicated on the return of the cylinder.

The zeroing is performed by the instrument when the TDC limit switch (cylinder backwards) is activated and
at the same time the index signal of the encoder appears. Therefore, for correct zeroing it is necessary to
ensure the presence of the index signal in the interval in which the limit switch is active.

If the encoder is mounted or replaced or if the top dead center of the cylinder is moved, it is necessary to
reposition the encoder correctly. To be able to do this, you must first reset the height offset in the instrument
calibration menu. Once the offset has been reset, it is possible to follow the instructions in the following
paragraphs.

16.3.1 M-OP type Alfamatic presses

Turn on the instrument and remove the cover covering the encoder, the rack and the TDC limit switch. Keeping
the limit switch pressed, rotate the encoder pinion until, on the instrument, you will see the value change which
will return to zero at a certain point. This is the exact position of the encoder index signal. Now rotate the pinion
back so that the instrument indicates a value between —-2.5 and —0.5 mm. Placement is finished.

To verify the exact positioning of the zero mark, switch the instrument off and on again: at this point the position
must be zero. Lower the cylinder with the lever and bring it back to the top: at this point the instrument must
display a negative value of a few millimetres.

16.3.2 For presses with pinion rack encoder

Turn on the instrument and open the rack lock cover. Inside you can see the rack and the encoder with its
pinion. Rotate the encoder pinion until, on the instrument display, you will see the value change and at a certain
point it will return to zero. This is the exact position of the encoder zero mark. Now rotate the pinion back so
that the instrument indicates a value between —2.5 and —0.5 mm. Placement is finished. To verify the exact
positioning of the zero mark, switch the instrument off and on again: at this point the position must be zero.
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Carry out a pressing cycle and check that, when the stem returns, the instrument displays a negative value of
a few millimetres.
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17 Connection to computer

The Press-Right can be connected to a computer. It is possible to connect the instrument to the computer via
USB port or LAN (Ethernet) port.

WinScope program is supplied together with the instrument, through which the potential of the instrument is
extended.

All the software can be downloaded from the website www.alfamatic.com.
17.1 Connection via USB port

If you are using the USB connection, you will need to use a standard USB Type A/B cable to plug into the
Press-Right's USB 1 port.

When you first connect the Press-Right to your computer, the operating system will look for drivers to properly
handle the device. For this reason, the first time you connect, your computer must have access to the Internet.

After installing the drivers, the instrument will automatically appear in the WinScope Connection menu.

17.2 Connection via LAN port (ethernet)

In order to use the Ethernet port, the instrument must first be assigned a static IP address. To do this, you
need access the TOOLS > SETUP > NETWORK AND CLOCK SETUP menu. After having assigned an IP
address to the instrument, it is necessary to add it to the list of usable ports in WinScope through the related
File > Preferences menu.

You can also set the IP address via Press-Right setup.
Install and run the Press-Right Setup program; Select the Set IP address command in the File menu.

&+ Press-Right Setup ot

File | Tools
Update CPU firmware...

Update VIO card firmware..,

Set IP address...
Initialize USE port EEPROM...

Test zeriale...

Format mermory...

Exit CTRL+Q

At this point the Alfamatic instruments present in the subnet are searched for by sending broadcast packets.
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Choose the instrument you want to assign the IP address to from the list that appears.

a5 Select >
Mame Port Irfo
Press-Right MAC:84.16.236.221.36.53 152.168.1.100
£ >
Fort: ||
QK Annulla

If the list is empty, check the Firewall status of your computer, if any. The Firewall can be disabled from the
Windows Control Panel.

If you can't tell which instrument to configure, just turn it off, redisplay the list, and see who's missing.

Once the instrument has been chosen, the following window appears with which it is possible to assign an IP
address:

ot Setup Ethernet port pe
Previous |P address: 192.168.1.100

IP address: 192.168.1.100 |

Subnet mask: | 255.255.255.0 |

Gateway address: |{I'.ﬂ'.1]'.ﬂ' |
ox
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18 Field bus

Press-Right instrument can communicate via Modbus TCP (standard), PROFINET (optional), or EtherNet/IP
(optional) fieldbuses.

18.1 Organization

The instrument has a list of registers that can be read or written via fieldbus communication.

Each register has an address. From the fieldbus it is possible to access the registers by indicating the address
of the same.

With the PROFINET and EtherNet/IP protocols, you have direct access to 11 read registers and 11 write
registers. You can decide which registers should be accessible directly. To do this you need the Press-Right
setup program. Access to a greater number of registers requires accessing through the address of the same.

18.2 Status and Control

The register at address 1 contains the instrument status bits.
The register at address 24 allows command of the instrument.
When writing a command (non-zero) the CMD_BUSY bit of the status register is raised.

18.3 Modbus/TCP

The instrument acts as a server and opens TCP port 502 for reception.

If a client with bank addressing is used, the value 40001 must be added to the address shown in the table. For
example, to access register 90, address 40091 must be used. With Siemens PLCs, the MB_MODE parameter
must be O for reading and 1 for writing.

Note:

When reading the registers, a 10 ms delay must be added between one reading and the next.

The registers must be read individually.

18.4 PROFINET and EtherNet/IP

From PLC you have access to 16 input variables and 16 output variables.

Through the first four input (CTRL_INPLC, SUBINDEX_INPLC, INDEX_INPLC, PV_INPLC) and output
(CTRL_OUTPLC, SUBINDEX_OUTPLC, INDEX_OUTPLC, PV_OUTPLC) variables itis possible to have read
and write access (if allowed) via address/data to all the instrument parameters .

The STATUS_WORD_INPLC input word contains the instrument status bits (register 1).

The CONTROL_WORD_OUTPLC output word contains the commands to be supplied to the instrument
(register 24).

The content of 11 input words (VAR1_INPLC ... VAR11 INPLC) and 11 output words (VAR1_OUTPLC ...
VAR11_OUTPLC) can be configured by the user using the Press-Right Setup software.
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The default content of these words is as follows:

2! FSetupFieldBus

PLC variable Register description Register name  Register. ..

VART_IM Actual job number Actlob 50 Click to modify
VARZ_IN Actual phase number ActPhase 91 Click to modify
VARI_IN Actual position of cylinder (ower word) ActPosttionH 3 Click to modify
VAR4_IM Actual force value Jower word) ActForceH 7 Click to modify
VARS_IMN Causes of the rejected piece (A bits) Cauzeh 2000 Click to modify
VARG_IM Causes of the rejected piece (B bits) CauzeB 2001 Click to modify
VART_IM Causes of the rejected piece (C bits) Causel 2002 Click to modify
VARB_IN Last peak value of force Peak Force 2008 Click to modify
VARS_IM Last peak value of position PealkPosition 2014 Click to modify
VART0_IN Last measured conctact position ContactPos 2015 Click to modify
VART1_IN Last measured value A at check point 1 ChkPrt1ValA 2017 Click to modify
VAR1_OUT Actual job number ActJob 50 Click to modify
VARZ_OUT Actual phase number ActPhase 51 Click to modify
YAR3I_OUT Target position for direct moving TargetPosti... 32 Click to modify
VAR4_OUT Speed for direct moving Speedl 13 Click to modify
VARS_OUT Dummy register Durmmy 1] Click to modify
VARE_OUT Dummy register Dummy 0 Click to modify
VART_OUT Dummy register Durmnmy 0 Click to modify
VARS_OUT Dummy register Durmmy 0 Click to modify
VARS_OUT Dummy register Dummy 1] Click to modify
VAR10_OUT  Dummy register Durmnmy 0 Click to modify
YAR11_OUT  Dummy register Durmmy 0 Click to modify

oK Annula

18.4.1 Access via address/data

18.4.1.1 Initialization
Load the value 0x00 into CTRL_OUTPLC
Wait for CTRL_INPLC to contain 0x00

18.4.1.2 Reading a 16-bit register
Load the register address into INDEX_OUTPLC
Load the value 0x40 into CTRL_OUTPLC

Wait for CTRL_INPLC to contain 0x10

Read the value from PV_INPPLC

Load the value 0x00 into CTRL_OUTPLC

Wait for CTRL_INPLC to contain 0x00

18.4.1.3 Reading a 32-bit register
Load the register address into INDEX_OUTPLC
Load the value 0x10 into CTRL_OUTPLC

Wait for CTRL_INPLC to contain 0x20

Read the value from PV_INPPLC

Load the value 0x00 into CTRL_OUTPLC

Wait for CTRL_INPLC to contain 0x00

18.4.1.4 Writing a 16-bit register
Load the register address into INDEX_OUTPLC
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Load the value to write into PV_OUTPLC

Load the value 0x20 into CTRL_OUTPLC
Wait for CTRL_INPLC to contain 0x10

In case of error CTRL_INPLC will contain 0x70
Load the value 0x00 into CTRL_OUTPLC
Wait for CTRL_INPLC to contain 0x00

18.4.1.5 Writing a 32-bit register
Load the register address into INDEX_OUTPLC
Load the value to write into PV_OUTPLC

Load the value 0x30 into CTRL_OUTPLC

Wait for CTRL_INPLC to contain 0x20

In case of error CTRL_INPLC will contain 0x70
Load the value 0x00 into CTRL_OUTPLC

Wait for CTRL_INPLC to contain 0x00

18.4.2 PROFINET interface notes

To install the GSD file in the library, select tools > device description file management.

In the library, it can be found under Additional field devices > PROFINET 10 > General > Alfamatic >
PressRight.

The device name and address are set by TIA:

Open the TIA, under "Online access" select "Update accessible nodes". It should appear immediately below
as CompactCom 40 PIR.

Open the device and in the "Functions" branch you will find set IP and set Name.
A new module is found automatically if it has the same IP address and the same name.

18.5 Strings

Strings are made up of single 8-bit ASCII characters.

For this reason, it is recommended to avoid accented letters.

Since each register has 16 bits, two characters fit into a single register.
The high byte of the register contains the first character of the pair.
The low byte of the register contains the second character of the pair.
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19 Registry organization

19.1 Execution of commands

By writing in the CONTROL_WORD_OUTPLC the press is commanded.

The command must be written until the Command BUSY bit of STATUS_WORD_INPLC goes high; at this you
can write zero in CONTROL_WORD_OUTPLC. Regardless of whether the command involves motion or not,
as long as the command is present the Command BUSY bit of STATUS_WORD_INPLC will remain high.

19.1.1 CONTROL_WORD_OUTPLC commands
The command register is accessible from Modbus at address 24.

Command 0
No command.
Command 2
Select the job with code equal to the text contained in the text buffer. The text buffer is located at address 45.

Note:
Before using command 2 it is necessary to load the desired code at address 45.

Command 3
Select the job with name equal to the text contained in the text buffer. The text buffer is located at address 45.

Note:
Before using command 3 it is necessary to load the name of the job to be activated at address 45.

Command 4
Sets the part code equal to the text contained in the text buffer. The text buffer is located at address 45.

Note:
Before using command 4 the part code must be loaded to address 45.

Command 6

When a job requires part code entry before machining, a warning message appears on the tool display. If you send the
part code with a scanner connected to the USB 2 port of the tool or via command 4, the message is cleared and the tool
becomes ready to do the job. This command cancels the code entry and causes the Part Code Request Message to
reappear.

Command 9

Forces re-reading of registers from fieldbus. This command is to be used after the phase change if you want to write the
operation parameters from fieldbus.

Command 10

Start cycle (start phase).

Note:

To use this command, an input must be configured as impulsive start.
The start is accepted only if bit O of the Status (ready) is active.

Command 20

Interrupts the cycle (stop phase).

Command 16

TOOLS > CONFIGURE > GENERAL OPTIONS > REQUEST SUPERVISION SYSTEM option on the instrument , the

instrument must be enabled after each cycle using this command.
After giving command 16, bit 6 of the status (Start enabled) becomes active.

Command 17

This command disables the instrument so that a phase start command is not accepted. To enable the tool, use command
16.

Command 18

Resets the job piece counters (registered at addresses 97 and 99). The general counter of the instrument (address 95)
cannot be reset.

Command 29

Sets the operator code equal to the text contained in the text buffer. The text buffer is located at address 45.

Note:
Before using command 4 the part code must be loaded to address 45.
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Command 30

Sets the operator job or order number equal to the text contained in the text buffer. The text buffer is located at address
45,

Note:

Before using command 4 the part code must be loaded to address 45.

Command 32

INSTRUMENTS > CONFIGURE > GENERAL OPTIONS > DISABLE RESET REJECTS FROM KEYBOARD is not active,
the instrument must be reset in case of reject. With this command it is possible to reset the reject via the fieldbus.

19.1.2 Status register STATUS _WORD _INPLC
The status register is accessible from ModbusTCP at address 1.

Position Firstname  Function

0

Ready Conditions to have bit 0 active (Ready):

Bit O The TDC input must be active or, if absent, the position must be less than 0.2 mm.

You must be outside the instrument menus.

There must be a job.

There should be no video messages.

With the TOOLS > CONFIGURE > GENERAL OPTIONS > REQUEST SUPERVISION
SYSTEM OPTION , Start must be enabled with command 16.

With the TOOLS > CONFIGURE > GENERAL OPTIONS > REQUEST CONNECTION WITH
COMPUTER OPTION, the computer must be connected (absence of exclamation mark on

the display)
Not used
Bits 1
Not used
Bits 2
] Start The start command 10 has been received. Command 20 turns this bit off.
Bits 3 request
Press Cylinder feed command. When the start command is given (10) this bit is activated. The PLC
Bits 4 must jog the cylinder until this bit is deactivated. This bit is deactivated when a stop value set

from the stop values menu is reached. The PLC must make the cylinder go back and wait for
the outcome of the cycle.

Note:

For best performance, a physical Press-Right output should be used instead of using this
signal.

Boosters This bit is useful with hydropneumatic cylinders for starting the cylinder booster. It is activated
when the cylinder is in contact with the workpiece.
Note:
For best performance, a physical Press-Right output should be used instead of using this
signal.

Enabled INSTRUMENTS > CONFIGURE > GENERAL OPTIONS > REQUEST
SUPERVISION SYSTEM option on the instrument , the instrument must be enabled after
each cycle via command 16. It is also possible to deactivate the instrument with command
17. This status bit indicates whether the instrument is it enabled or not.

New Part New part number

Number
Not used

Result OK  The outcome of the cycle performed is good because the measured values fall within the
control parameters set in the job.
Note:
This bit can be reset by command 16 or command 17.

[y
o

Result KO  The outcome of the cycle performed is rejected because the measured values do not fall
within the control parameters set in the job.
Note:
This bit can be reset by command 16 or command 17.

N
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Command

BUSY

Not used

Not used

Not used

Not used

Note: Siemens PLCs have the high and low byte positions reversed.

19.2 Register table

Name

Dummy

Status and Flags

PositionAct

SupplAct

ForceAct

Statuslnputs

StatusOutputs

Control Word

Statusinputs

StatusOutputs

ToolA

ToolB

ToolC

StringBuffer

Jobindex

PhaseAct

PhaseValue

MainCounter

JobNumOK

Content

See chapter 19.1.2

Current position of the cylinder

Current value of additional transducer

Current force

Status of digital inputs (from version 3.23)

Status and control of digital outputs (from version 3.23)
See chapter 19.1.1

Status of digital inputs (from version 3.23)

Status and control of digital outputs (from version 3.23)
ID of tool A (from version 2.19)

ID of tool B (from version 2.19)

ID of tool C (from version 2.19)

Textbuffer

Job index

Phase number

The first phase is number 1

Phase number to accessing values
With zero, you access to phase to execute

Main counter

Number of good pieces (to reset use control word = 18)

Indicates the presence of a command received on the fieldbus.

Guy

UINT16

INT32

INT32

INT32

UINT16

UINT16

UINT16

UINT16

UINT16

UINT16

UINT16

UINT16

STRING 24L

UINT16

UINT16

UINT16

UINT32

UINT32

pos.

40

41

24

40

41

42

43

44

45

90

91

ninet

two
95

97

Access

Read only

Read only

Read only

Read only

Read only

Write/read

Write

Read only

Write/read

Read only

Read only

Read only

Write/read

Write/read

Write/read

Write/read

Read only

Read only
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JobNumNOK

MaxNumOK

PartNumber

decimalsY
UnitY
decimalsX
UnitX
DecimalsP
UnitP

InstrumentName

JobName

StopPosition

StopForce

StopDelay

ContactForce

PhaseOptionsA

PeakPosMin

PeakPosMax

PeakForceMin

PeakForceMax

InitPosMin

InitPosMax

CP1lparl

CP1par2

CP1par3

CP1lpar4

CP1par5

CP2parl

CP2par2

46

Number of rejected pieces (to reset use control word =

18)

Maximum number of good pieces

Queues

Number of decimals digit of the force values
Unit of measurement of the force values
Number of decimals digit of the position values
Unit of measurement of the position values
Number of decimal digits of the probe values
Unit of measurement of the probe values

Name of the instrument (len max: 15 characters)

Name of current job (len max: 24 characters)

Stop position

Stop force

Delay before return (from version 1.86)

Force for contact detection (from version 1.94)

BITO: RELATIVE POSITIONS

Minimum value of reached position

Maximum value of reached position

Minimum value of reached force

Maximum value of reached force

Minimum value of contact position

Maximum value of contact position

First value of checkpoint 1

Second value of check point 1

Third value of check point 1

Fourth value of check point 1

Fifth value of check point 1

First value of check point 2

Second value of check point 2

UINT32

UINT32

STRING 28L

UINT16
UINT16
UINT16
UINT16
UINT16
UINT16

STRING 7L

STRING 12L

UINT16

UINT16

UINT16

UINT16

UINT16

UINT16

UINT16

UINT16

UINT16

UINT16

UINT16

UINT16

UINT16

UINT16

UINT16

UINT16

UINT16

UINT16

99

101

103

207
208
209
210
211
212

213

1000

1014

1015

1024

1025

1026

1027

1028

1029

1030

1031

1032

1033

1034

1035

1036

1037

1038

1039

Read only

Write/read

Read only

Read only
Read only
Read only
Read only
Read only
Read only

Read only

Read only

Write/read

Write/read

Write/read

Write/read

Read only

Write/read

Write/read

Write/read

Write/read

Write/read

Write/read

Write/read

Write/read

Write/read

Write/read

Write/read

Write/read

Write/read



CP2par3

CP2par4

CP2par5

CP3parl

CP3par2

CP3par3

CP3par4

CP3par5

CP4parl

CP4par2

CP4par3

CP4par4

CP4par5

CP5parl

CP5par2

CP5par3

CP5par4

CP5par5

ProbeStop

ProbeMin

Probe Max

PhaseName

JobCodel

JobCode2

JobCode3

JobCode4

JobCode5

Third value of check point 2

Fourth value of check point 2

Fifth value of check point 2

First value of checkpoints 3

Second value of check point 3

Third value of check point 3

Fourth value of check point 3

Fifth value of check point 3

First value of check point 4

Second value of check point 4

Third value of check point 4

Fourth value of check point 4

Fifth value of check point 4

First value of check point 5

Second value of check point 5

Third value of check point 5

Fourth value of check point 5

Fifth value of check point 5

Stop value of external probe

Minimum value of external probe

Maximum value of external probe

Name of current phase

Code of current job

Code of current job

Code of current job

Code of current job

Code of current job

UINT16

UINT16

UINT16

UINT16

UINT16

UINT16

UINT16

UINT16

UINT16

UINT16

UINT16

UINT16

UINT16

UINT16

UINT16

UINT16

UINT16

UINT16

UINT16

UINT16

UINT16

STRING 14L

STRING 24L

STRING 24L

STRING 24L

STRING 24L

STRING 24L

1040

1041

1042

1043

1044

1045

1046

1047

1048

1049

1050

1051

1052

1053

1054

1055

1056

1057

1068

1069

1070

1100

1114

1128

1142

1156

1170

Write/read

Write/read

Write/read

Write/read

Write/read

Write/read

Write/read

Write/read

Write/read

Write/read

Write/read

Write/read

Write/read

Write/read

Write/read

Write/read

Write/read

Write/read

Write/read

Write/read

Write/read

Read only

Read only

Read only

Read only

Read only

Read only

47



JobCode6 Code of current job STRING 24L 1184 Read only

JobCode7 Code of current job STRING 24L 1198 Read only
OrderNumber Order number STRING 24L 1212 Read only
Operator Operator ID STRING24L 12 i Read only
Issue A BITO: STOP FROM USER INTERFACE UINT16 2000 Read only

BIT1: STOP FROM INPUTS SIGNALS
BIT2: TIME OUT
BIT3: MAX PROBE
BIT4: MIN PROBE
BIT5: PROBE ERROR
BIT6: HIGH SPEED
BIT7: LOW SPEED
Issue B BITO: MAX POSITION UINT16 2001 Read only
BIT1: MIN POSITION
BIT2: MAX CONTACT
BIT3: MIN CONTACT
BIT4: MAX CHECK POINT
BIT5: MIN CHECK POINT
BIT6: TEST INPUT 2
BIT7: TEST INPUT 3
Issue C BIT4: MAX FORCE UINT16 2002 Read only
BIT5: MIN FORCE
BIT6: MAX BAND
BIT7: MIN BAND

PeakForce Force reached UINT16 2008 Read only
PeakPosition Position reached UINT16 2014 Read only
ContactPos Contact position UINT16 2015 Read only
ProbeValue Probe measured UINT16 2016 Read only
CP1ValueA Value A at check point 1 UINT16 2017 Read only
CP1ValueB Value B at check point 1 UINT16 2018 Read only
CP2ValueA Value A at check point 2 UINT16 2019 Read only
CP2ValueB Value B at checkpoint 2 UINT16 2020 Read only
CP3ValueA Value A at check point 3 UINT16 2021 Read only
CP3ValueB Value B at check point 3 UINT16 2022 Read only
CP4ValueA Value A at check point 4 UINT16 2023 Read only
CP4ValueB Value B at check point 4 UINT16 2024 Read only
CP5ValueA Value A at check point 5 UINT16 2025 Read only
CP5ValueB Value B at check point 5 UINT16 2026 Read only

* To have the ready signal, the reject piece signal must be reset. To activate the auto reset you need to activate
the option “Disable reset rejects from keyboard”.
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19.3 Description of Check Point logs

Checkpoints are described by five different parameters: CPxParl, CPxPar2, CPxPar3, CPxPar4, CPxPar5.
The function of these parameters varies according to the type of check point.

Thank you, you have a check point, for each piece worked, the instrument measures one or two values. These

values are available in registers CPxValueA and CPxValueB.
The type of check point is indicated by the three least significant bits of parameter 5 (CPxParb5).

The types currently available are as follows:
CP_FORCE =011b

CP_POSITION = 100b

CP_PEAK = 001b

CP_SPEED = 000b

CP_SETPOINT = 101b

19.3.1 Force check point logs

Register Function Value type

CPxParl Force measurement dimension Quote

CPxPar2 Minimum force limit Force

CPxPar3 Maximum force limit Force

CPxValueA Measured strength Force
19.3.2 Position check point logs

Register Function Value type

CPxParl Height measurement force Force

CPxPar2 Minimum position limit Quote

CPxPar3 Maximum position limit Quote

CPxValueA Measured position Quote
19.3.3 Peak check point logs

Register Function Value type

CPxParl Start position measurement minimum maximum Quote

values
CPxPar2 End of measurement position minimum maximum Quote
values

CPxValueA Minimum measured value Force

CPxValueB Maximum measured value Force
19.3.4 Log check point speed

Register Function Value type

CPxParl Speed measurement start position Quote

CPxPar2 Speed measurement end value Quote

CPxValueA Speed Speed
19.3.5 Setpoint checkpoint registers

Register Function Value type

CPxParl Setpoint 1 activation position Quote
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CPxPar2 Setpoint 2 activation value Quote
CPxPar3 Setpoint 3 activation value Quote

19.4 Description unit of measure

The following table contains the correspondence between the contents of the register with the unit of measure
and the unit of measure to be used:

Index First name Unit of
measure

0 decanewton daN

1 kilonewton kN

2 Newtons No

6 Millimeters mm

7 Micrometer pm
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20 Technical data

The list of technical characteristics follows:

Subject ‘ Characteristics

DC version power supply 24VDC

Absorption 1A (excluding transducer absorption and input/output)
Sampling rate 1000 samples/second
Dimensions Width: 205mm

Height: 175mm
Depth: 240mm

Length of accepted codes A maximum of 38 are accepted but only one part is stored indicating the
start and length of the useful part

Part serial number length Maximum 28 characters with the possibility of cutting longer codes

Job identification code length Maximum 24 characters

Number of codes associated Maximum 7

with individual jobs

Operator code length Maximum 24 characters

Maximum job number length 24 characters

20.1 Instrument features

The Press-Right detects the position-force curve during work.

Work on a continuous band of tolerance by controlling the entire position-force curve.
Check the elevation and peak force values.

Controls the stop of the press when a position or a force is reached.

Check the starting position measured in contact with the piece.

Check critical values of the position-force curve through check-points.

It manages up to four consecutive phases with independent parameters.

All control parameters are stored in 250 independent and selectable jobs.

Advanced management of users with passwords and personal authorizations.

It is possible to connect the Press-Right to the computer and, thanks to the WinScope program, save the
curves, modify the settings, carry out statistical analyses, print the data.

Saving of curves on internal microSD memory card accessible via FTP.

Job selection by barcode reading.

Registration of the serial number of the piece by reading the barcode.

Management of three antennas for the recognition of the equipment through RFID tags.
Allows the connection of three enable signals.

Allows connection of three additional pass/fail control signals.

Programmable periodic request for tool replacement due to wear.

Programmable periodic maintenance request.

Integrated management of a small pick-to-light system.
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This image indicates that this appliance cannot be disposed of with unsorted domestic waste
but must be disposed of separately. At the end of use, please send the appliance to Alfamatic
to reduce the waste of materials and resources.
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